# CVE-2025-57821: Basecamp's Google Sign-In for Rails allowed redirects to a malformed URL

> Attackers can redirect users to malicious sites via malformed URLs, potentially enabling session cookie injection attacks in Rails applications.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Aug 2025
- **Updated:** 27 Aug 2025
- **Also known as:** GHSA-7pwc-wh6m-44q3

## What is CVE-2025-57821?

CVE-2025-57821 is a medium-severity vulnerability in basecamp google_sign_in, published on 27 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Basecamp's Google Sign-In adds Google sign-in to Rails applications. Prior to version 1.3.0, it is possible to craft a malformed URL that passes the "same origin" check, resulting in the user being redirected to another origin. Rails applications configured to store the flash information in a session cookie may be vulnerable, if this can be chained with an attack that allows injection of arbitrary data into the session cookie. This issue has been patched in version 1.3.0. If upgrading is not possible at this time, a way to mitigate the chained attack can be done by explicitly setting SameSite=Lax or SameSite=Strict on the application session cookie.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2025-57821?

2 open source packages ship an affected version, including google_sign_in.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `google_sign_in` | RubyGems | All versions | 1.3.0 |
| `google_sign_in` | RubyGems | All versions | 1.3.0 |

## How do I fix CVE-2025-57821?

Upgrade google_sign_in to 1.3.0 or later.

## Is CVE-2025-57821 being exploited?

There is no known exploitation of CVE-2025-57821 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-57821 and fix it if it is affected.

What it is: CVE-2025-57821 is a medium-severity vulnerability in basecamp google_sign_in, published on 27 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-57821 in the wild and no public exploit code.

Affected packages and fixed versions:
- google_sign_in (RubyGems): affected all versions; fixed in 1.3.0
- google_sign_in (RubyGems): affected all versions; fixed in 1.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-57821/ (Markdown: https://insights.sbomify.com/CVE-2025-57821/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-57821
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-57821
- OSV: https://osv.dev/vulnerability/CVE-2025-57821

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-57821/
Summaries are generated and may contain mistakes; the official description above is the record.
