# CVE-2025-57822: Next.js Improper Middleware Redirect Handling Leads to SSRF

> Attackers can exploit improper middleware redirect handling in self-hosted Next.js apps to perform Server-Side Request Forgery.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Aug 2025
- **Updated:** 2 Sep 2025
- **Also known as:** GHSA-4342-x723-ch2f, MINI-2j35-m87x-wrqg, ROOT-APP-NPM-CVE-2025-57822

## What is CVE-2025-57822?

CVE-2025-57822 is a medium-severity server-side request forgery vulnerability in Vercel Next.js, published on 29 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Next.js is a React framework for building full-stack web applications. Prior to versions 14.2.32 and 15.4.7, when next() was used without explicitly passing the request object, it could lead to SSRF in self-hosted applications that incorrectly forwarded user-supplied headers. This vulnerability has been fixed in Next.js versions 14.2.32 and 15.4.7. All users implementing custom middleware logic in self-hosted environments are strongly encouraged to upgrade and verify correct usage of the next() function.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2025-57822?

4 open source packages ship an affected version, including next. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `next` | npm | From 0.9.9 | 14.2.32 |
| `next` | npm | From 0.9.9 | 14.2.32 |
| `next` | npm | From 15.0.0-canary.0 | 15.4.7 |
| `next` | npm | From 15.0.0-canary.0 | 15.4.7 |

Products: Vercel Next.js.

## How do I fix CVE-2025-57822?

Upgrade next to a fixed version for your release line: 14.2.32 or 15.4.7.

## Is CVE-2025-57822 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-57822 exists.

Public exploit code:

- Next.js Middleware - Server-Side Request Forgery (nuclei): http/cves/2025/CVE-2025-57822.yaml

## Other vulnerabilities in Vercel Next.js

- [CVE-2025-29927](https://insights.sbomify.com/CVE-2025-29927/): Authorization Bypass in Next.js Middleware (critical 9.1)
- [CVE-2026-44578](https://insights.sbomify.com/CVE-2026-44578/): Next.js: Server-side request forgery in applications using WebSocket upgrades (high 8.6)
- [CVE-2026-94483](https://insights.sbomify.com/CVE-2026-94483/): Next.js: Server-Side Request Forgery in Image Optimization (high 8.3)
- [CVE-2026-64642](https://insights.sbomify.com/CVE-2026-64642/): Next.js: Middleware / Proxy bypass in App Router applications using Turbopack and single locale (high 8.3)
- [CVE-2026-64645](https://insights.sbomify.com/CVE-2026-64645/): Next.js: Server-Side Request Forgery in rewrites via attacker-controlled destination hostname (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-57822 and fix it if it is affected.

What it is: CVE-2025-57822 is a medium-severity server-side request forgery vulnerability in Vercel Next.js, published on 29 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-57822 exists.

Affected packages and fixed versions:
- next (npm): affected from 0.9.9; fixed in 14.2.32
- next (npm): affected from 0.9.9; fixed in 14.2.32
- next (npm): affected from 15.0.0-canary.0; fixed in 15.4.7
- next (npm): affected from 15.0.0-canary.0; fixed in 15.4.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-57822/ (Markdown: https://insights.sbomify.com/CVE-2025-57822/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-57822
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-57822
- OSV: https://osv.dev/vulnerability/CVE-2025-57822

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-57822/
Summaries are generated and may contain mistakes; the official description above is the record.
