CVE-2025-57833 Django is subject to SQL injection through its column aliases
Attackers can execute SQL injection via crafted dictionary arguments in Django's QuerySet.annotate or alias methods, potentially reading or modifying database data.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-57833?
CVE-2025-57833 is a high-severity SQL injection vulnerability in Djangoproject Django, published on 3 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue was discovered in Django 4.2 before 4.2.24, 5.1 before 5.1.12, and 5.2 before 5.2.6. FilteredRelation is subject to SQL injection in column aliases, using a suitably crafted dictionary, with dictionary expansion, as the **kwargs passed QuerySet.annotate() or QuerySet.alias().
Weakness: CWE-89
Which versions are affected by CVE-2025-57833?
8 open source packages ship an affected version, including django and Django. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
django Bitnami | All versions | 4.2.24, 5.1.12, 5.2.6 |
django PyPI | All versions | 4.2.24 |
django PyPI | From 4.2 | 4.2.24, 5.1.12, 5.2.6 |
django PyPI | From 5.0a1 | 5.1.12 |
django PyPI | From 5.2a1 | 5.2.6 |
Django PyPI | All versions | 4.2.24 |
2 more packages
Django PyPI | From 5.0a1 | 5.1.12 |
Django PyPI | From 5.2a1 | 5.2.6 |
Linux distribution packages (15)
python39-django Red Hat:ansible_automation_platform:2.4::el8 | All versions | 0:4.2.24-1.el8ap |
python3x-django Red Hat:ansible_automation_platform:2.4::el8 | All versions | 0:4.2.24-1.el8ap |
python-django Red Hat:ansible_automation_platform:2.4::el9 | All versions | 0:4.2.24-1.el9ap |
python3-django Red Hat:ansible_automation_platform:2.4::el9 | All versions | 0:4.2.24-1.el9ap |
python-django20 Red Hat:openstack:16.2::el8 | All versions | 0:2.0.13-20.el8ost |
python3-django20 Red Hat:openstack:16.2::el8 | All versions | 0:2.0.13-20.el8ost |
python-django Red Hat:openstack:17.1::el9 | All versions | 0:2.2.24-12.el9ost |
python3-django Red Hat:openstack:17.1::el9 | All versions | 0:2.2.24-12.el9ost |
python-django Red Hat:openstack:18.0::el9 | All versions | 0:3.2.12-9.el9ost |
python3-django Red Hat:openstack:18.0::el9 | All versions | 0:3.2.12-9.el9ost |
python-Django SUSE:Linux Enterprise Module for Package Hub 15 SP6 | All versions | 4.2.11-150600.3.30.1 |
python-Django SUSE:Linux Enterprise Module for Package Hub 15 SP7 | All versions | 4.2.11-150600.3.30.1 |
python-Django openSUSE:Leap 15.6 | All versions | 4.2.11-150600.3.30.1 |
python-Django openSUSE:Tumbleweed | All versions | 5.2.6-1.1 |
python-Django4 openSUSE:Tumbleweed | All versions | 4.2.24-1.1 |
Products include Djangoproject Django.
How do I fix CVE-2025-57833?
Upgrade django to a fixed version for your release line: 4.2.24, 5.1.12 or 5.2.6.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2025-57833 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-57833 exists.
Public exploit code: 5 proofs of concept on GitHub.
Other vulnerabilities in Djangoproject Django
- CVE-2026-4277 Privilege abuse in GenericInlineModelAdmin
- CVE-2024-53908 Django SQL injection in HasKey(lhs, rhs) on Oracle
- CVE-2024-42005 Django SQL injection vulnerability
- CVE-2023-31047 Django bypasses validation when using one form field to upload multiple files
- CVE-2022-34265 Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection
Sources
Also known as BIT-django-2025-57833, CLSA-2026-1787142559, CLSA-2026-1788862060, CLSA-2026-1789475134, CLSA-2026-1790339542, CLSA-2026-1790830085 and 23 more.