# CVE-2025-57833: Django is subject to SQL injection through its column aliases

> Attackers can execute SQL injection via crafted dictionary arguments in Django's QuerySet.annotate or alias methods, potentially reading or modifying database data.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Sep 2025
- **Updated:** 4 Nov 2025
- **Also known as:** BIT-django-2025-57833, CLSA-2026-1787142559, CLSA-2026-1788862060, CLSA-2026-1789475134, CLSA-2026-1790339542, CLSA-2026-1790830085, CLSA-2026-1790830102, DEBIAN-CVE-2025-57833, DLA-4301-1, ECHO-7627-a361-b4d3, GHSA-6w2r-r2m5-xq5w, MGASA-2025-0229, OESA-2025-2231, OESA-2025-2234, OESA-2025-2235, OESA-2025-2236, OESA-2025-2237, OESA-2025-2354, PYSEC-2025-105, RHSA-2025:16403, RHSA-2025:17498, RHSA-2025:17499, RHSA-2025:17500, ROOT-APP-PYPI-CVE-2025-57833, SUSE-SU-2025:03074-1, UBUNTU-CVE-2025-57833, USN-7736-1, openSUSE-SU-2025:15527-1, openSUSE-SU-2025:15528-1

## What is CVE-2025-57833?

CVE-2025-57833 is a high-severity SQL injection vulnerability in Djangoproject Django, published on 3 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue was discovered in Django 4.2 before 4.2.24, 5.1 before 5.1.12, and 5.2 before 5.2.6. FilteredRelation is subject to SQL injection in column aliases, using a suitably crafted dictionary, with dictionary expansion, as the **kwargs passed QuerySet.annotate() or QuerySet.alias().

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2025-57833?

8 open source packages ship an affected version, including django and Django. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | Bitnami | All versions | 4.2.24, 5.1.12, 5.2.6 |
| `django` | PyPI | All versions | 4.2.24 |
| `django` | PyPI | From 4.2 | 4.2.24, 5.1.12, 5.2.6 |
| `django` | PyPI | From 5.0a1 | 5.1.12 |
| `django` | PyPI | From 5.2a1 | 5.2.6 |
| `Django` | PyPI | All versions | 4.2.24 |
| `Django` | PyPI | From 5.0a1 | 5.1.12 |
| `Django` | PyPI | From 5.2a1 | 5.2.6 |
| `python39-django` | Red Hat:ansible_automation_platform:2.4::el8 | All versions | 0:4.2.24-1.el8ap |
| `python3x-django` | Red Hat:ansible_automation_platform:2.4::el8 | All versions | 0:4.2.24-1.el8ap |
| `python-django` | Red Hat:ansible_automation_platform:2.4::el9 | All versions | 0:4.2.24-1.el9ap |
| `python3-django` | Red Hat:ansible_automation_platform:2.4::el9 | All versions | 0:4.2.24-1.el9ap |
| `python-django20` | Red Hat:openstack:16.2::el8 | All versions | 0:2.0.13-20.el8ost |
| `python3-django20` | Red Hat:openstack:16.2::el8 | All versions | 0:2.0.13-20.el8ost |
| `python-django` | Red Hat:openstack:17.1::el9 | All versions | 0:2.2.24-12.el9ost |
| `python3-django` | Red Hat:openstack:17.1::el9 | All versions | 0:2.2.24-12.el9ost |
| `python-django` | Red Hat:openstack:18.0::el9 | All versions | 0:3.2.12-9.el9ost |
| `python3-django` | Red Hat:openstack:18.0::el9 | All versions | 0:3.2.12-9.el9ost |
| `python-Django` | SUSE:Linux Enterprise Module for Package Hub 15 SP6 | All versions | 4.2.11-150600.3.30.1 |
| `python-Django` | SUSE:Linux Enterprise Module for Package Hub 15 SP7 | All versions | 4.2.11-150600.3.30.1 |
| `python-Django` | openSUSE:Leap 15.6 | All versions | 4.2.11-150600.3.30.1 |
| `python-Django` | openSUSE:Tumbleweed | All versions | 5.2.6-1.1 |
| `python-Django4` | openSUSE:Tumbleweed | All versions | 4.2.24-1.1 |

Products: Djangoproject Django.

## How do I fix CVE-2025-57833?

Upgrade django to a fixed version for your release line: 4.2.24, 5.1.12 or 5.2.6.

## Is CVE-2025-57833 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-57833 exists.

Public exploit code:

- Analysis and reproduction of CVE-2025-57833 (github_poc): https://github.com/sw0rd1ight/CVE-2025-57833
- We've set up an environment to test CVE-2025-57833. This environment was built using AI, so it's subject to ongoing modification. (github_poc): https://github.com/Mkway/CVE-2025-57833
- https://github.com/loic-houchi/Django-faille-CVE-2025-57833_test (github_poc): https://github.com/loic-houchi/Django-faille-CVE-2025-57833_test
- Example Vulnerable application for CVE-2025–57833 (github_poc): https://github.com/ianoboyle/CVE-2025-57833
- CVE-2025-57833 PoC (취약한 도서 검색 서비스) (github_poc): https://github.com/Gayang2902/CVE-2025-57833

## Other vulnerabilities in Djangoproject Django

- [CVE-2026-4277](https://insights.sbomify.com/CVE-2026-4277/): Privilege abuse in GenericInlineModelAdmin (critical 9.8)
- [CVE-2024-53908](https://insights.sbomify.com/CVE-2024-53908/): Django SQL injection in HasKey(lhs, rhs) on Oracle (critical 9.8)
- [CVE-2024-42005](https://insights.sbomify.com/CVE-2024-42005/): Django SQL injection vulnerability (critical 9.8)
- [CVE-2023-31047](https://insights.sbomify.com/CVE-2023-31047/): Django bypasses validation when using one form field to upload multiple files (critical 9.8)
- [CVE-2022-34265](https://insights.sbomify.com/CVE-2022-34265/): Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-57833 and fix it if it is affected.

What it is: CVE-2025-57833 is a high-severity SQL injection vulnerability in Djangoproject Django, published on 3 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-57833 exists.

Affected packages and fixed versions:
- django (Bitnami): affected all versions; fixed in 4.2.24, 5.1.12, 5.2.6
- django (PyPI): affected all versions; fixed in 4.2.24
- django (PyPI): affected from 4.2; fixed in 4.2.24, 5.1.12, 5.2.6
- django (PyPI): affected from 5.0a1; fixed in 5.1.12
- django (PyPI): affected from 5.2a1; fixed in 5.2.6
- Django (PyPI): affected all versions; fixed in 4.2.24
- Django (PyPI): affected from 5.0a1; fixed in 5.1.12
- Django (PyPI): affected from 5.2a1; fixed in 5.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-57833/ (Markdown: https://insights.sbomify.com/CVE-2025-57833/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-57833
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-57833
- OSV: https://osv.dev/vulnerability/CVE-2025-57833

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-57833/
Summaries are generated and may contain mistakes; the official description above is the record.
