{"answers":{"affected":"3 open source packages ship an affected version, including users.","exploited":"There is no known exploitation of CVE-2025-5791 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2025-5791 is a high-severity vulnerability in Red Hat Enterprise Linux 10, published on 6 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-5791 and fix it if it is affected.\n\nWhat it is: CVE-2025-5791 is a high-severity vulnerability in Red Hat Enterprise Linux 10, published on 6 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-5791 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- users (crates.io): affected from 0.8.0; no fix listed\n- users (crates.io): affected from 0.8.0 up to 0.11.0; no fix listed\n- users (crates.io): affected from 0.8.0 up to 0.11.0; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-5791/ (Markdown: https://insights.sbomify.com/CVE-2025-5791/index.md)","id":"CVE-2025-5791","markdown":"https://insights.sbomify.com/CVE-2025-5791/index.md","name":"CVE-2025-5791","record":{"aliases":["AZL-63771","AZL-63848","GHSA-m65q-v92h-cm7q","RUSTSEC-2025-0040","SUSE-RU-2025:20961-1","SUSE-RU-2025:21046-1","UBUNTU-CVE-2025-5791","openSUSE-SU-2025:15246-1","openSUSE-SU-2025:15335-1","openSUSE-SU-2025:15412-1","openSUSE-SU-2025:15628-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Rust users crate","requires_auth":"low_privilege","summary":"A flaw in the Rust users crate allows privilege escalation by incorrectly appending the root group to access lists for users with fewer than 1024 groups.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-266","name":"Incorrect Privilege Assignment"}],"description":"A flaw was found in the user's crate for Rust. This vulnerability allows privilege escalation via incorrect group listing when a user or process has fewer than exactly 1024 groups, leading to the erroneous inclusion of the root group in the access list.","ecosystems":["SUSE:Linux Micro 6.0","SUSE:Linux Micro 6.1","crates.io","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Users: `root` appended to group listings","id":"CVE-2025-5791","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"privilege_escalation","year":"2025"},"n_packages":9,"n_references":6,"next":{"headline":"TOTOLINK EX1200T HTTP POST Request formWlanRedirect buffer overflow","id":"CVE-2025-5792"},"packages":[{"ecosystem":"crates.io","fixed":[],"introduced":["0.8.0"],"last_affected":[],"package":"users","purl":"pkg:cargo/users","source":"RUSTSEC-2025-0040"},{"ecosystem":"crates.io","fixed":[],"introduced":["0.8.0"],"last_affected":["0.11.0"],"package":"users","purl":null,"source":"GHSA-m65q-v92h-cm7q"},{"ecosystem":"crates.io","fixed":[],"introduced":["0.8.0"],"last_affected":["0.11.0"],"package":"users","purl":"pkg:cargo/users","source":"GHSA-m65q-v92h-cm7q"},{"ecosystem":"SUSE:Linux Micro 6.0","fixed":["5.9.0.git21.a73f509-1.1"],"introduced":["0"],"last_affected":[],"package":"afterburn","purl":"pkg:rpm/suse/afterburn\u0026distro=SUSE%20Linux%20Micro%206.0","source":"SUSE-RU-2025:21046-1"},{"ecosystem":"SUSE:Linux Micro 6.1","fixed":["5.9.0.git21.a73f509-slfo.1.1_1.1"],"introduced":["0"],"last_affected":[],"package":"afterburn","purl":"pkg:rpm/suse/afterburn\u0026distro=SUSE%20Linux%20Micro%206.1","source":"SUSE-RU-2025:20961-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["5.8.2-3.1"],"introduced":["0"],"last_affected":[],"package":"afterburn","purl":"pkg:rpm/opensuse/afterburn\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15335-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["17+60.68fdb92ec-26.1"],"introduced":["0"],"last_affected":[],"package":"agama","purl":"pkg:rpm/opensuse/agama\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15412-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.2.0-1.1"],"introduced":["0"],"last_affected":[],"package":"lsd","purl":"pkg:rpm/opensuse/lsd\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15628-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.1.3~1-1.1"],"introduced":["0"],"last_affected":[],"package":"mirrorsorcerer","purl":"pkg:rpm/opensuse/mirrorsorcerer\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15246-1"}],"prev":{"headline":"TOTOLINK X15 HTTP POST Request formIpQoS buffer overflow","id":"CVE-2025-5790"},"products":["Red Hat Enterprise Linux 10","Red Hat Enterprise Linux 9","Red Hat OpenShift Container Platform 4","Red Hat OpenShift sandboxed containers 1.1","Red Hat Trusted Profile Analyzer"],"published":"2025-06-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-11-20","vendors":["Red Hat"]},"summary":"A flaw in the Rust users crate allows privilege escalation by incorrectly appending the root group to access lists for users with fewer than 1024 groups.","url":"https://insights.sbomify.com/CVE-2025-5791/"}