# CVE-2025-58046: Dataease has a JDBC attack vulnerability in the Impala datasource

> Attackers can achieve remote code execution in Dataease by exploiting JNDI injection and RMI deserialization via malicious JDBC connection strings in the Impala datasource.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Sep 2025
- **Updated:** 15 Sep 2025
- **Also known as:** GHSA-mvwc-x8x9-46c3

## What is CVE-2025-58046?

CVE-2025-58046 is a high-severity unsafe deserialization vulnerability in Dataease Dataease, published on 15 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Dataease is an open-source data visualization and analysis platform. In versions up to and including 2.10.12, the Impala data source is vulnerable to remote code execution due to insufficient filtering in the getJdbc method of the io.dataease.datasource.type.Impala class. Attackers can construct malicious JDBC connection strings that exploit JNDI injection and trigger RMI deserialization, ultimately enabling remote command execution. The vulnerability can be exploited by editing the data source and providing a crafted JDBC connection string that references a remote configuration file, leading to RMI-based deserialization attacks. This issue has been patched in version 2.10.13. It is recommended to upgrade to the latest version. No known workarounds exist for affected versions.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-58046?

It affects 1 product.


Products: Dataease Dataease.

## How do I fix CVE-2025-58046?

No fix has been published for CVE-2025-58046 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-58046 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-58046 exists.

## Other vulnerabilities in Dataease Dataease

- [CVE-2024-57707](https://insights.sbomify.com/CVE-2024-57707/): Code injection in n/a (critical 9.8)
- [CVE-2024-46997](https://insights.sbomify.com/CVE-2024-46997/): DataEase's H2 datasource has a remote command execution risk (critical 9.8)
- [CVE-2023-33963](https://insights.sbomify.com/CVE-2023-33963/): DataEase data source has deserialization vulnerability (critical 9.8)
- [CVE-2023-28437](https://insights.sbomify.com/CVE-2023-28437/): SQL injection vulnerability due to the keyword blacklist for defending against SQL injection will be bypassed (critical 9.8)
- [CVE-2022-39312](https://insights.sbomify.com/CVE-2022-39312/): Dataease Mysql Data Source JDBC Connection Parameters Not Verified Leads to Deserialization Vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58046 and fix it if it is affected.

What it is: CVE-2025-58046 is a high-severity unsafe deserialization vulnerability in Dataease Dataease, published on 15 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-58046 exists.

Affected product: Dataease Dataease. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58046/ (Markdown: https://insights.sbomify.com/CVE-2025-58046/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58046
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58046
- OSV: https://osv.dev/vulnerability/CVE-2025-58046

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58046/
Summaries are generated and may contain mistakes; the official description above is the record.
