{"answers":{"affected":"2 open source packages ship an affected version, including paymenter/paymenter.","exploited":"There is no known exploitation of CVE-2025-58048 in the wild and no public exploit code.","fix":"Upgrade paymenter/paymenter to 1.2.11 or later.","what":"CVE-2025-58048 is a critical vulnerability in Paymenter, published on 28 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-58048 and fix it if it is affected.\n\nWhat it is: CVE-2025-58048 is a critical vulnerability in Paymenter, published on 28 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-58048 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- paymenter/paymenter (Packagist): affected all versions; fixed in 1.2.11\n- paymenter/paymenter (Packagist): affected all versions; fixed in 1.2.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-58048/ (Markdown: https://insights.sbomify.com/CVE-2025-58048/index.md)","id":"CVE-2025-58048","markdown":"https://insights.sbomify.com/CVE-2025-58048/index.md","name":"CVE-2025-58048","record":{"aliases":["GHSA-5pm9-r2m8-rcmj"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Paymenter webshop","requires_auth":"low_privilege","summary":"Authenticated users can upload arbitrary files to execute code and read sensitive data in Paymenter webshop.","user_interaction":"not_required","vuln_class":"file_upload"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":10,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-434","name":"Unrestricted Upload of File with Dangerous Type"}],"description":"Paymenter is a free and open-source webshop solution for hostings. Prior to version 1.2.11, the ticket attachments functionality in Paymenter allows a malicious authenticated user to upload arbitrary files. This could result in sensitive data extraction from the database, credentials being read from configuration files, and arbitrary system commands being run under the web server user context. This vulnerability was patched by commit 87c3db4 and was released under the version 1.2.11 tag without any other code modifications compared to version 1.2.10. If upgrading is not immediately possible, administrators can mitigate this vulnerability with one or more of the following measures: updating nginx config to download attachments instead of executing them or disallowing access to /storage/ fully using a WAF such as Cloudflare.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Paymenter Vulnerable to Remote Code Execution via Public File Uploads","id":"CVE-2025-58048","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"file_upload","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"XWiki PDF export jobs store sensitive cookies unencrypted in job statuses","id":"CVE-2025-58049"},"packages":[{"ecosystem":"Packagist","fixed":["1.2.11"],"introduced":["0"],"last_affected":[],"package":"paymenter/paymenter","purl":null,"source":"GHSA-5pm9-r2m8-rcmj"},{"ecosystem":"Packagist","fixed":["1.2.11"],"introduced":["0"],"last_affected":[],"package":"paymenter/paymenter","purl":"pkg:composer/paymenter/paymenter","source":"GHSA-5pm9-r2m8-rcmj"}],"prev":{"headline":"Volto affected by possible DoS by invoking specific URL by anonymous user","id":"CVE-2025-58047"},"products":["Paymenter"],"published":"2025-08-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-08-28","vendors":["Paymenter"]},"summary":"Authenticated users can upload arbitrary files to execute code and read sensitive data in Paymenter webshop.","url":"https://insights.sbomify.com/CVE-2025-58048/"}