# CVE-2025-58048: Paymenter Vulnerable to Remote Code Execution via Public File Uploads

> Authenticated users can upload arbitrary files to execute code and read sensitive data in Paymenter webshop.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Aug 2025
- **Updated:** 28 Aug 2025
- **Also known as:** GHSA-5pm9-r2m8-rcmj

## What is CVE-2025-58048?

CVE-2025-58048 is a critical vulnerability in Paymenter, published on 28 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Paymenter is a free and open-source webshop solution for hostings. Prior to version 1.2.11, the ticket attachments functionality in Paymenter allows a malicious authenticated user to upload arbitrary files. This could result in sensitive data extraction from the database, credentials being read from configuration files, and arbitrary system commands being run under the web server user context. This vulnerability was patched by commit 87c3db4 and was released under the version 1.2.11 tag without any other code modifications compared to version 1.2.10. If upgrading is not immediately possible, administrators can mitigate this vulnerability with one or more of the following measures: updating nginx config to download attachments instead of executing them or disallowing access to /storage/ fully using a WAF such as Cloudflare.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2025-58048?

2 open source packages ship an affected version, including paymenter/paymenter.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `paymenter/paymenter` | Packagist | All versions | 1.2.11 |
| `paymenter/paymenter` | Packagist | All versions | 1.2.11 |

## How do I fix CVE-2025-58048?

Upgrade paymenter/paymenter to 1.2.11 or later.

## Is CVE-2025-58048 being exploited?

There is no known exploitation of CVE-2025-58048 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58048 and fix it if it is affected.

What it is: CVE-2025-58048 is a critical vulnerability in Paymenter, published on 28 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-58048 in the wild and no public exploit code.

Affected packages and fixed versions:
- paymenter/paymenter (Packagist): affected all versions; fixed in 1.2.11
- paymenter/paymenter (Packagist): affected all versions; fixed in 1.2.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58048/ (Markdown: https://insights.sbomify.com/CVE-2025-58048/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58048
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58048
- OSV: https://osv.dev/vulnerability/CVE-2025-58048

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58048/
Summaries are generated and may contain mistakes; the official description above is the record.
