# CVE-2025-58049: XWiki PDF export jobs store sensitive cookies unencrypted in job statuses

> Attackers with access to job status data can read unencrypted sensitive cookies, potentially leading to account takeover.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Aug 2025
- **Updated:** 28 Aug 2025
- **Also known as:** GHSA-9m7c-m33f-3429

## What is CVE-2025-58049?

CVE-2025-58049 is a medium-severity vulnerability in Xwiki Xwiki, published on 28 Aug 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. In versions from 14.4.2 to before 16.4.8, 16.5.0-rc-1 to before 16.10.7, and 17.0.0-rc-1 to before 17.4.0-rc-1, the PDF export jobs store sensitive cookies unencrypted in job statuses. XWiki shouldn't store passwords in plain text, and it shouldn't be possible to gain access to plain text passwords by gaining access to, e.g., a backup of the data directory. This vulnerability has been patched in XWiki 16.4.8, 16.10.7, and 17.4.0-rc-1.

Weakness: CWE-257 (Storing Passwords in a Recoverable Format), CWE-212 (Improper Removal of Sensitive Information Before Storage or Transfer)

## Which versions are affected by CVE-2025-58049?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-export-pdf-api. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-export-pdf-api` | Maven | From 14.4.2 | 16.4.8 |
| `org.xwiki.platform:xwiki-platform-export-pdf-api` | Maven | From 14.4.2 | 16.4.8 |
| `org.xwiki.platform:xwiki-platform-export-pdf-api` | Maven | From 16.5.0-rc-1 | 16.10.7 |
| `org.xwiki.platform:xwiki-platform-export-pdf-api` | Maven | From 16.5.0-rc-1 | 16.10.7 |
| `org.xwiki.platform:xwiki-platform-export-pdf-api` | Maven | From 17.0.0-rc-1 | 17.4.0-rc-1 |
| `org.xwiki.platform:xwiki-platform-export-pdf-api` | Maven | From 17.0.0-rc-1 | 17.4.0-rc-1 |

Products: Xwiki Xwiki.

## How do I fix CVE-2025-58049?

Upgrade org.xwiki.platform:xwiki-platform-export-pdf-api to a fixed version for your release line: 16.4.8, 16.10.7 or 17.4.0-rc-1.

## Is CVE-2025-58049 being exploited?

There is no known exploitation of CVE-2025-58049 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58049 and fix it if it is affected.

What it is: CVE-2025-58049 is a medium-severity vulnerability in Xwiki Xwiki, published on 28 Aug 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-58049 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-export-pdf-api (Maven): affected from 14.4.2; fixed in 16.4.8
- org.xwiki.platform:xwiki-platform-export-pdf-api (Maven): affected from 14.4.2; fixed in 16.4.8
- org.xwiki.platform:xwiki-platform-export-pdf-api (Maven): affected from 16.5.0-rc-1; fixed in 16.10.7
- org.xwiki.platform:xwiki-platform-export-pdf-api (Maven): affected from 16.5.0-rc-1; fixed in 16.10.7
- org.xwiki.platform:xwiki-platform-export-pdf-api (Maven): affected from 17.0.0-rc-1; fixed in 17.4.0-rc-1
- org.xwiki.platform:xwiki-platform-export-pdf-api (Maven): affected from 17.0.0-rc-1; fixed in 17.4.0-rc-1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58049/ (Markdown: https://insights.sbomify.com/CVE-2025-58049/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58049
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58049
- OSV: https://osv.dev/vulnerability/CVE-2025-58049

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58049/
Summaries are generated and may contain mistakes; the official description above is the record.
