{"answers":{"affected":"1 open source package ship an affected version, including pcre2. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-58050 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2025-58050 is a medium-severity memory corruption vulnerability in PCRE2Project pcre2, published on 27 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-58050 and fix it if it is affected.\n\nWhat it is: CVE-2025-58050 is a medium-severity memory corruption vulnerability in PCRE2Project pcre2, published on 27 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-58050 exists.\n\nAffected packages and fixed versions:\n- pcre2 (PyPI): affected all versions up to 10.45; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-58050/ (Markdown: https://insights.sbomify.com/CVE-2025-58050/index.md)","id":"CVE-2025-58050","markdown":"https://insights.sbomify.com/CVE-2025-58050/index.md","name":"CVE-2025-58050","record":{"aliases":["ALPINE-CVE-2025-58050","BELL-CVE-2025-58050","DEBIAN-CVE-2025-58050","GHSA-c2gv-xgf5-5cc2","JLSEC-2026-60","MINI-q86x-4f29-q5jr","PYSEC-2025-259","ROOT-OS-UBUNTU-2204-CVE-2025-58050","SUSE-SU-2026:21094-1","SUSE-SU-2026:21172-1","USN-7777-1","openSUSE-SU-2025:15501-1","openSUSE-SU-2026:20512-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PCRE2 regex library","requires_auth":"none","summary":"A heap-buffer-overflow in PCRE2 allows attackers to read out-of-bounds memory, potentially causing information disclosure or crashes.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"pcre2","vendor":"pcre"}],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:L/SC:L/SI:N/SA:L","version":"4.0"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"},{"id":"CWE-125","name":"Out-of-bounds Read"},{"id":"CWE-122","name":"Heap-based Buffer Overflow"}],"description":"The PCRE2 library is a set of C functions that implement regular expression pattern matching. In version 10.45, a heap-buffer-overflow read vulnerability exists in the PCRE2 regular expression matching engine, specifically within the handling of the (*scs:...) (Scan SubString) verb when combined with (*ACCEPT) in src/pcre2_match.c. This vulnerability may potentially lead to information disclosure if the out-of-bounds data read during the memcmp affects the final match result in a way observable by the attacker. This issue has been resolved in version 10.46.","ecosystems":["PyPI","SUSE:Linux Enterprise Server 16.0","SUSE:Linux Enterprise Server for SAP applications 16.0","SUSE:Linux Micro 6.2","openSUSE:Leap 16.0","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"PCRE2: heap-buffer-overflow read in match_ref due to missing boundary restoration in SCS","id":"CVE-2025-58050","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"memory_corruption","year":"2025"},"n_packages":6,"n_references":3,"next":{"headline":"Nextcloud Tables app allowed to include local file via PhpSpreadsheet when importing a table","id":"CVE-2025-58051"},"packages":[{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["10.45"],"package":"pcre2","purl":"pkg:pypi/pcre2","source":"PYSEC-2025-259"},{"ecosystem":"SUSE:Linux Enterprise Server 16.0","fixed":["10.45-160000.3.1"],"introduced":["0"],"last_affected":[],"package":"pcre2","purl":"pkg:rpm/suse/pcre2\u0026distro=SUSE%20Linux%20Enterprise%20Server%2016.0","source":"SUSE-SU-2026:21172-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP applications 16.0","fixed":["10.45-160000.3.1"],"introduced":["0"],"last_affected":[],"package":"pcre2","purl":"pkg:rpm/suse/pcre2\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20applications%2016.0","source":"SUSE-SU-2026:21172-1"},{"ecosystem":"SUSE:Linux Micro 6.2","fixed":["10.45-160000.3.1"],"introduced":["0"],"last_affected":[],"package":"pcre2","purl":"pkg:rpm/suse/pcre2\u0026distro=SUSE%20Linux%20Micro%206.2","source":"SUSE-SU-2026:21094-1"},{"ecosystem":"openSUSE:Leap 16.0","fixed":["10.45-160000.3.1"],"introduced":["0"],"last_affected":[],"package":"pcre2","purl":"pkg:rpm/opensuse/pcre2\u0026distro=openSUSE%20Leap%2016.0","source":"openSUSE-SU-2026:20512-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["10.46-1.1"],"introduced":["0"],"last_affected":[],"package":"pcre2","purl":"pkg:rpm/opensuse/pcre2\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15501-1"}],"prev":{"headline":"XWiki PDF export jobs store sensitive cookies unencrypted in job statuses","id":"CVE-2025-58049"},"products":["pcre2"],"published":"2025-08-27","related":[{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2017-8786","kev_date_added":null,"published":"2017-05-05"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2017-8399","kev_date_added":null,"published":"2017-05-01"},{"cvss_score":7.5,"headline":"Integer overflow in n/a","id":"CVE-2022-41409","kev_date_added":null,"published":"2023-07-18"},{"cvss_score":7.4,"headline":"Use after free in PCRE2","id":"CVE-2026-89161","kev_date_added":null,"published":"2026-09-11"},{"cvss_score":6.5,"headline":"Integer overflow in PCRE2","id":"CVE-2026-89158","kev_date_added":null,"published":"2026-09-11"},{"cvss_score":5.7,"headline":"Memory corruption in PCRE2","id":"CVE-2026-89157","kev_date_added":null,"published":"2026-09-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-08-27","vendors":["PCRE2Project"]},"summary":"A heap-buffer-overflow in PCRE2 allows attackers to read out-of-bounds memory, potentially causing information disclosure or crashes.","url":"https://insights.sbomify.com/CVE-2025-58050/"}