CVE-2025-58054 Discourse is vulnerable to XSS when quoting chat messages

Low 3.5 Published Updated

Attackers can execute arbitrary scripts via chat message quoting, potentially compromising user accounts and session integrity.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-58054?

CVE-2025-58054 is a low-severity cross-site scripting vulnerability in Discourse Discourse, published on 1 Oct 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Discourse is an open-source community discussion platform. Versions 3.5.0 and below are vulnerable to XSS attacks through parsing and rendering of chat channel titles and chat thread titles via the quote message functionality when using the rich text editor. This issue is fixed in version 3.5.1.

Weakness: CWE-80

Which versions are affected by CVE-2025-58054?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions3.5.1

Products include Discourse Discourse.

How do I fix CVE-2025-58054?

Upgrade discourse to 3.5.1 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-58054 being exploited?

There is no known exploitation of CVE-2025-58054 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2025-58054, GHSA-7p47-8m82-m2vf.

Is CVE-2025-58054 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free