CVE-2025-58055 Discourse AI Suggestions Contain Insecure Direct Object Reference

Medium 4.3 Published Updated

Authenticated users can access restricted topic information via AI suggestion endpoints by modifying topic IDs, exposing unauthorized data.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-58055?

CVE-2025-58055 is a medium-severity missing authorization vulnerability in Discourse Discourse, published on 1 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Discourse is an open-source community discussion platform. In versions 3.5.0 and below, the Discourse AI suggestion endpoints for topic “Title”, “Category”, and “Tags” allowed authenticated users to extract information about topics that they weren’t authorized to access. By modifying the “topic_id” value in API requests to the AI suggestion endpoints, users could target specific restricted topics. The AI model’s responses then disclosed information that the authenticated user couldn’t normally access. This issue is fixed in version 3.5.1. To workaround this issue, users can restrict group access to the AI helper feature through the "composer_ai_helper_allowed_groups" and "post_ai_helper_allowed_groups" site settings.

Weakness: CWE-639, CWE-284

Which versions are affected by CVE-2025-58055?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions3.5.1

Products include Discourse Discourse.

How do I fix CVE-2025-58055?

Upgrade discourse to 3.5.1 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-58055 being exploited?

There is no known exploitation of CVE-2025-58055 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2025-58055, GHSA-32v2-x274-vfhr.

Is CVE-2025-58055 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free