# CVE-2025-58055: Discourse AI Suggestions Contain Insecure Direct Object Reference

> Authenticated users can access restricted topic information via AI suggestion endpoints by modifying topic IDs, exposing unauthorized data.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Oct 2025
- **Updated:** 23 Oct 2025
- **Also known as:** BIT-discourse-2025-58055, GHSA-32v2-x274-vfhr

## What is CVE-2025-58055?

CVE-2025-58055 is a medium-severity missing authorization vulnerability in Discourse Discourse, published on 1 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Discourse is an open-source community discussion platform. In versions 3.5.0 and below, the Discourse AI suggestion endpoints for topic “Title”, “Category”, and “Tags” allowed authenticated users to extract information about topics that they weren’t authorized to access. By modifying the “topic_id” value in API requests to the AI suggestion endpoints, users could target specific restricted topics. The AI model’s responses then disclosed information that the authenticated user couldn’t normally access. This issue is fixed in version 3.5.1. To workaround this issue, users can restrict group access to the AI helper feature through the "composer_ai_helper_allowed_groups" and "post_ai_helper_allowed_groups" site settings.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2025-58055?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 3.5.1 |

Products: Discourse Discourse.

## How do I fix CVE-2025-58055?

Upgrade discourse to 3.5.1 or later.

## Is CVE-2025-58055 being exploited?

There is no known exploitation of CVE-2025-58055 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58055 and fix it if it is affected.

What it is: CVE-2025-58055 is a medium-severity missing authorization vulnerability in Discourse Discourse, published on 1 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-58055 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 3.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58055/ (Markdown: https://insights.sbomify.com/CVE-2025-58055/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58055
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58055
- OSV: https://osv.dev/vulnerability/CVE-2025-58055

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58055/
Summaries are generated and may contain mistakes; the official description above is the record.
