CVE-2025-58057 Netty's BrotliDecoder is vulnerable to DoS via zip bomb style attack

Medium 6.9 Published Updated

Attackers can cause denial of service in Netty applications by sending crafted input that triggers excessive memory allocation in the BrotliDecoder.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-58057?

CVE-2025-58057 is a medium-severity denial of service vulnerability in Netty Netty, published on 3 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Netty is an asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. In netty-codec-compression versions 4.1.124.Final and below, and netty-codec versions 4.2.4.Final and below, when supplied with specially crafted input, BrotliDecoder and certain other decompression decoders will allocate a large number of reachable byte buffers, which can lead to denial of service. BrotliDecoder.decompress has no limit in how often it calls pull, decompressing data 64K bytes at a time. The buffers are saved in the output list, and remain reachable until OOM is hit. This is fixed in versions 4.1.125.Final of netty-codec and 4.2.5.Final of netty-codec-compression.

Weakness: CWE-409

Which versions are affected by CVE-2025-58057?

4 open source packages ship an affected version, including io.netty:netty-codec and io.netty:netty-codec-compression. It affects 1 product.

PackageAffectedFixed in
io.netty:netty-codec MavenAll versions4.1.125.Final
io.netty:netty-codec MavenAll versions4.1.125.Final
io.netty:netty-codec-compression MavenFrom 4.2.0.Alpha14.2.5.Final
io.netty:netty-codec-compression MavenFrom 4.2.0.Alpha14.2.5.Final

Products include Netty Netty.

How do I fix CVE-2025-58057?

Upgrade io.netty:netty-codec to 4.1.125.Final or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-58057 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-58057 exists.

All Netty Netty vulnerabilities

Sources

Also known as CLEANSTART-2026-DD70897, CLEANSTART-2026-DW10612, CLEANSTART-2026-HA94391, CLEANSTART-2026-TU89159, CLEANSTART-2026-UI06484, CLSA-2026-1777336751 and 54 more.

Is CVE-2025-58057 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free