CVE-2025-58059 Valtimo scripting engine can be used to gain access to sensitive data or resources
Admins can execute arbitrary code via scripting engines to access sensitive data and run executables on the host.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-58059?
CVE-2025-58059 is a critical code injection vulnerability in valtimo-platform valtimo-backend-libraries, published on 28 Aug 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Valtimo is a platform for Business Process Automation. In versions before 12.16.0.RELEASE, and from 13.0.0.RELEASE to before 13.1.2.RELEASE, any admin that can create or modify and execute process-definitions could gain access to sensitive data or resources. This includes but is not limited to: running executables on the application host, inspecting and extracting data from the host environment or application properties, spring beans (application context, database pooling). The following conditions have to be met in order to perform this attack: the user must be logged in, have the admin role, and must have some knowledge about running scripts via a the Camunda/Operator engine. Version 12.16.0 and 13.1.2 have been patched. It is strongly advised to upgrade. If no scripting is needed in any of the processes, it could be possible to disable it altogether via the ProcessEngineConfiguration. However, this workaround could lead to unexpected side-effects.
Which versions are affected by CVE-2025-58059?
4 open source packages ship an affected version, including com.ritense.valtimo:core.
| Package | Affected | Fixed in |
|---|---|---|
com.ritense.valtimo:core Maven | All versions | 12.16.0.RELEASE |
com.ritense.valtimo:core Maven | All versions | 12.16.0.RELEASE |
com.ritense.valtimo:core Maven | From 13.0.0.RELEASE | 13.1.2.RELEASE |
com.ritense.valtimo:core Maven | From 13.0.0.RELEASE | 13.1.2.RELEASE |
How do I fix CVE-2025-58059?
Upgrade com.ritense.valtimo:core to a fixed version for your release line: 12.16.0.RELEASE or 13.1.2.RELEASE.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2025-58059 being exploited?
There is no known exploitation of CVE-2025-58059 in the wild and no public exploit code.
Sources
Also known as GHSA-w48j-pp7j-fj55.