# CVE-2025-58059: Valtimo scripting engine can be used to gain access to sensitive data or resources

> Admins can execute arbitrary code via scripting engines to access sensitive data and run executables on the host.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Aug 2025
- **Updated:** 28 Aug 2025
- **Also known as:** GHSA-w48j-pp7j-fj55

## What is CVE-2025-58059?

CVE-2025-58059 is a critical code injection vulnerability in valtimo-platform valtimo-backend-libraries, published on 28 Aug 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Valtimo is a platform for Business Process Automation. In versions before 12.16.0.RELEASE, and from 13.0.0.RELEASE to before 13.1.2.RELEASE, any admin that can create or modify and execute process-definitions could gain access to sensitive data or resources. This includes but is not limited to: running executables on the application host, inspecting and extracting data from the host environment or application properties, spring beans (application context, database pooling). The following conditions have to be met in order to perform this attack: the user must be logged in, have the admin role, and must have some knowledge about running scripts via a the Camunda/Operator engine. Version 12.16.0 and 13.1.2 have been patched. It is strongly advised to upgrade. If no scripting is needed in any of the processes, it could be possible to disable it altogether via the ProcessEngineConfiguration. However, this workaround could lead to unexpected side-effects.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-58059?

4 open source packages ship an affected version, including com.ritense.valtimo:core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.ritense.valtimo:core` | Maven | All versions | 12.16.0.RELEASE |
| `com.ritense.valtimo:core` | Maven | All versions | 12.16.0.RELEASE |
| `com.ritense.valtimo:core` | Maven | From 13.0.0.RELEASE | 13.1.2.RELEASE |
| `com.ritense.valtimo:core` | Maven | From 13.0.0.RELEASE | 13.1.2.RELEASE |

## How do I fix CVE-2025-58059?

Upgrade com.ritense.valtimo:core to a fixed version for your release line: 12.16.0.RELEASE or 13.1.2.RELEASE.

## Is CVE-2025-58059 being exploited?

There is no known exploitation of CVE-2025-58059 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58059 and fix it if it is affected.

What it is: CVE-2025-58059 is a critical code injection vulnerability in valtimo-platform valtimo-backend-libraries, published on 28 Aug 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-58059 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.ritense.valtimo:core (Maven): affected all versions; fixed in 12.16.0.RELEASE
- com.ritense.valtimo:core (Maven): affected all versions; fixed in 12.16.0.RELEASE
- com.ritense.valtimo:core (Maven): affected from 13.0.0.RELEASE; fixed in 13.1.2.RELEASE
- com.ritense.valtimo:core (Maven): affected from 13.0.0.RELEASE; fixed in 13.1.2.RELEASE

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58059/ (Markdown: https://insights.sbomify.com/CVE-2025-58059/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58059
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58059
- OSV: https://osv.dev/vulnerability/CVE-2025-58059

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58059/
Summaries are generated and may contain mistakes; the official description above is the record.
