# CVE-2025-58061: OpenEBS Local PV RawFile persistent volume data is world readable

> Non-privileged users can access sensitive persistent volume data due to world-readable permissions in OpenEBS Local PV RawFile.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 28 Aug 2025
- **Updated:** 29 Aug 2025
- **Also known as:** GHSA-wh95-vw4r-xwx4

## What is CVE-2025-58061?

CVE-2025-58061 is a medium-severity vulnerability in openebs rawfile-localpv, published on 28 Aug 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

OpenEBS Local PV RawFile allows dynamic deployment of Stateful Persistent Node-Local Volumes & Filesystems for Kubernetes. Prior to version 0.10.0, persistent volume data is world readable and that would allow non-privileged users to access sensitive data such as databases of k8s workload. The rawfile-localpv storage class creates persistent volume data under /var/csi/rawfile/ on Kubernetes hosts by default. However, the directory and data in it are world-readable. It allows non-privileged users to access the whole persistent volume data, and those can include sensitive information such as a whole database if the Kubernetes tenants are running MySQL or PostgreSQL in a container so it could lead to a database breach. This issue has been patched in version 0.10.0.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-58061?


## How do I fix CVE-2025-58061?

No fix has been published for CVE-2025-58061 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-58061 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-58061 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58061 and fix it if it is affected.

What it is: CVE-2025-58061 is a medium-severity vulnerability in openebs rawfile-localpv, published on 28 Aug 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-58061 exists.

Affected product: openebs rawfile-localpv. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58061/ (Markdown: https://insights.sbomify.com/CVE-2025-58061/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58061
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58061
- OSV: https://osv.dev/vulnerability/CVE-2025-58061

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58061/
Summaries are generated and may contain mistakes; the official description above is the record.
