{"answers":{"affected":"3 open source packages ship an affected version, including github.com/coredns/coredns.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-58063 exists.","fix":"Upgrade github.com/coredns/coredns to 1.12.4 or later.","what":"CVE-2025-58063 is a high-severity denial of service vulnerability in coredns, published on 9 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-58063 and fix it if it is affected.\n\nWhat it is: CVE-2025-58063 is a high-severity denial of service vulnerability in coredns, published on 9 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-58063 exists.\n\nAffected packages and fixed versions:\n- github.com/coredns/coredns (Go): affected from 1.2.0; fixed in 1.12.4\n- github.com/coredns/coredns (Go): affected from 1.2.0; fixed in 1.12.4\n- github.com/coredns/coredns (Go): affected from 1.2.0; fixed in 1.12.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-58063/ (Markdown: https://insights.sbomify.com/CVE-2025-58063/index.md)","id":"CVE-2025-58063","markdown":"https://insights.sbomify.com/CVE-2025-58063/index.md","name":"CVE-2025-58063","record":{"aliases":["AZL-67097","AZL-67101","CLEANSTART-2026-PA51754","ECHO-e94f-2815-5e57","GHSA-93mf-426m-g6x9","GO-2025-3942","MINI-68g3-34ph-qc43","MINI-8j7g-r3xj-fg73","MINI-ff6v-28v9-84mm","MINI-fjfp-hv43-fxmj","MINI-g8px-wg8p-6mpr","MINI-p2v6-4wg4-qgj9","OESA-2026-2720","openSUSE-SU-2025:15561-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"CoreDNS server","requires_auth":"low_privilege","summary":"Attackers can cause DNS resolution denial of service by exploiting etcd lease ID confusion to pin DNS cache entries with excessive TTLs.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H","version":"3.1"},"cwes":[{"id":"CWE-681","name":"Incorrect Conversion between Numeric Types"}],"description":"CoreDNS is a DNS server that chains plugins. Starting in version 1.2.0 and prior to version 1.12.4, the CoreDNS etcd plugin contains a TTL confusion vulnerability where lease IDs are incorrectly used as TTL values, enabling DNS cache pinning attacks. This effectively creates a DoS condition for DNS resolution of affected services. The `TTL()` function in `plugin/etcd/etcd.go` incorrectly casts etcd lease IDs (64-bit integers) to uint32 and uses them as TTL values. Large lease IDs become very large TTLs when cast to uint32. This enables cache pinning attacks. Version 1.12.4 contains a fix for the issue.","ecosystems":["Go","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"CoreDNS: DNS Cache Pinning via etcd Lease ID Confusion","id":"CVE-2025-58063","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":4,"n_references":2,"next":{"headline":"CKEditor is susceptible to Cross-Site Scripting (XSS) through its clipboard package","id":"CVE-2025-58064"},"packages":[{"ecosystem":"Go","fixed":["1.12.4"],"introduced":["1.2.0"],"last_affected":[],"package":"github.com/coredns/coredns","purl":null,"source":"GHSA-93mf-426m-g6x9"},{"ecosystem":"Go","fixed":["1.12.4"],"introduced":["1.2.0"],"last_affected":[],"package":"github.com/coredns/coredns","purl":"pkg:golang/github.com/coredns/coredns","source":"GHSA-93mf-426m-g6x9"},{"ecosystem":"Go","fixed":["1.12.4"],"introduced":["1.2.0"],"last_affected":[],"package":"github.com/coredns/coredns","purl":"pkg:golang/github.com/coredns/coredns","source":"GO-2025-3942"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.12.4-2.1"],"introduced":["0"],"last_affected":[],"package":"coredns","purl":"pkg:rpm/opensuse/coredns\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15561-1"}],"prev":{"headline":"LSTM-Kirigaya's openmcp-client Vulnerable to RCE in MCP Authorization Flow","id":"CVE-2025-58062"},"products":["coredns"],"published":"2025-09-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-09-10","vendors":["coredns"]},"summary":"Attackers can cause DNS resolution denial of service by exploiting etcd lease ID confusion to pin DNS cache entries with excessive TTLs.","url":"https://insights.sbomify.com/CVE-2025-58063/"}