# CVE-2025-58063: CoreDNS: DNS Cache Pinning via etcd Lease ID Confusion

> Attackers can cause DNS resolution denial of service by exploiting etcd lease ID confusion to pin DNS cache entries with excessive TTLs.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Sep 2025
- **Updated:** 10 Sep 2025
- **Also known as:** AZL-67097, AZL-67101, CLEANSTART-2026-PA51754, ECHO-e94f-2815-5e57, GHSA-93mf-426m-g6x9, GO-2025-3942, MINI-68g3-34ph-qc43, MINI-8j7g-r3xj-fg73, MINI-ff6v-28v9-84mm, MINI-fjfp-hv43-fxmj, MINI-g8px-wg8p-6mpr, MINI-p2v6-4wg4-qgj9, OESA-2026-2720, openSUSE-SU-2025:15561-1

## What is CVE-2025-58063?

CVE-2025-58063 is a high-severity denial of service vulnerability in coredns, published on 9 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

CoreDNS is a DNS server that chains plugins. Starting in version 1.2.0 and prior to version 1.12.4, the CoreDNS etcd plugin contains a TTL confusion vulnerability where lease IDs are incorrectly used as TTL values, enabling DNS cache pinning attacks. This effectively creates a DoS condition for DNS resolution of affected services. The `TTL()` function in `plugin/etcd/etcd.go` incorrectly casts etcd lease IDs (64-bit integers) to uint32 and uses them as TTL values. Large lease IDs become very large TTLs when cast to uint32. This enables cache pinning attacks. Version 1.12.4 contains a fix for the issue.

Weakness: CWE-681 (Incorrect Conversion between Numeric Types)

## Which versions are affected by CVE-2025-58063?

3 open source packages ship an affected version, including github.com/coredns/coredns.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/coredns/coredns` | Go | From 1.2.0 | 1.12.4 |
| `github.com/coredns/coredns` | Go | From 1.2.0 | 1.12.4 |
| `github.com/coredns/coredns` | Go | From 1.2.0 | 1.12.4 |
| `coredns` | openSUSE:Tumbleweed | All versions | 1.12.4-2.1 |

## How do I fix CVE-2025-58063?

Upgrade github.com/coredns/coredns to 1.12.4 or later.

## Is CVE-2025-58063 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-58063 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58063 and fix it if it is affected.

What it is: CVE-2025-58063 is a high-severity denial of service vulnerability in coredns, published on 9 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-58063 exists.

Affected packages and fixed versions:
- github.com/coredns/coredns (Go): affected from 1.2.0; fixed in 1.12.4
- github.com/coredns/coredns (Go): affected from 1.2.0; fixed in 1.12.4
- github.com/coredns/coredns (Go): affected from 1.2.0; fixed in 1.12.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58063/ (Markdown: https://insights.sbomify.com/CVE-2025-58063/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58063
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58063
- OSV: https://osv.dev/vulnerability/CVE-2025-58063

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58063/
Summaries are generated and may contain mistakes; the official description above is the record.
