CVE-2025-58064 CKEditor is susceptible to Cross-Site Scripting (XSS) through its clipboard package
Attackers can execute unauthorized JavaScript via malicious content in CKEditor 5 if specific plugins or configurations are enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-58064?
CVE-2025-58064 is a low-severity cross-site scripting vulnerability in ckeditor5, published on 3 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. ckeditor5 and ckeditor5-clipboard versions 46.0.0 through 46.0.2 and 44.2.0 through 45.2.1 contain a Cross-Site Scripting (XSS) vulnerability. Ability to exploit could be triggered by a specific user action (leading to unauthorized JavaScript code execution) if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration. This vulnerability affects installations where the editor configuration meets one of the following criteria: the HTML embed plugin is enabled, or there is a custom plugin introducing an editable element where view RawElement is enabled. This issue is fixed in versions 45.2.2 and 46.0.3 of both ckeditor5 and ckeditor5-clipboard.
Weakness: CWE-79
Which versions are affected by CVE-2025-58064?
8 open source packages ship an affected version, including @ckeditor/ckeditor5-clipboard and ckeditor5.
| Package | Affected | Fixed in |
|---|---|---|
@ckeditor/ckeditor5-clipboard npm | From 44.2.0 | 45.2.2 |
@ckeditor/ckeditor5-clipboard npm | From 44.2.0 | 45.2.2 |
@ckeditor/ckeditor5-clipboard npm | From 46.0.0 | 46.0.3 |
@ckeditor/ckeditor5-clipboard npm | From 46.0.0 | 46.0.3 |
ckeditor5 npm | From 44.2.0 | 45.2.2 |
ckeditor5 npm | From 44.2.0 | 45.2.2 |
2 more packages
ckeditor5 npm | From 46.0.0 | 46.0.3 |
ckeditor5 npm | From 46.0.0 | 46.0.3 |
How do I fix CVE-2025-58064?
Upgrade @ckeditor/ckeditor5-clipboard to a fixed version for your release line: 45.2.2 or 46.0.3.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2025-58064 being exploited?
There is no known exploitation of CVE-2025-58064 in the wild and no public exploit code.
Sources
Also known as GHSA-x9gp-vjh6-3wv6.