{"answers":{"affected":"8 open source packages ship an affected version, including @ckeditor/ckeditor5-clipboard and ckeditor5.","exploited":"There is no known exploitation of CVE-2025-58064 in the wild and no public exploit code.","fix":"Upgrade @ckeditor/ckeditor5-clipboard to a fixed version for your release line: 45.2.2 or 46.0.3.","what":"CVE-2025-58064 is a low-severity cross-site scripting vulnerability in ckeditor5, published on 3 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-58064 and fix it if it is affected.\n\nWhat it is: CVE-2025-58064 is a low-severity cross-site scripting vulnerability in ckeditor5, published on 3 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-58064 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @ckeditor/ckeditor5-clipboard (npm): affected from 44.2.0; fixed in 45.2.2\n- @ckeditor/ckeditor5-clipboard (npm): affected from 44.2.0; fixed in 45.2.2\n- @ckeditor/ckeditor5-clipboard (npm): affected from 46.0.0; fixed in 46.0.3\n- @ckeditor/ckeditor5-clipboard (npm): affected from 46.0.0; fixed in 46.0.3\n- ckeditor5 (npm): affected from 44.2.0; fixed in 45.2.2\n- ckeditor5 (npm): affected from 44.2.0; fixed in 45.2.2\n- ckeditor5 (npm): affected from 46.0.0; fixed in 46.0.3\n- ckeditor5 (npm): affected from 46.0.0; fixed in 46.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-58064/ (Markdown: https://insights.sbomify.com/CVE-2025-58064/index.md)","id":"CVE-2025-58064","markdown":"https://insights.sbomify.com/CVE-2025-58064/index.md","name":"CVE-2025-58064","record":{"aliases":["GHSA-x9gp-vjh6-3wv6"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"JavaScript rich-text editor","requires_auth":"none","summary":"Attackers can execute unauthorized JavaScript via malicious content in CKEditor 5 if specific plugins or configurations are enabled.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":2.3,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. ckeditor5 and ckeditor5-clipboard versions 46.0.0 through 46.0.2 and 44.2.0 through 45.2.1 contain a Cross-Site Scripting (XSS) vulnerability. Ability to exploit could be triggered by a specific user action (leading to unauthorized JavaScript code execution) if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration. This vulnerability affects installations where the editor configuration meets one of the following criteria: the HTML embed plugin is enabled, or there is a custom plugin introducing an editable element where view RawElement is enabled. This issue is fixed in versions 45.2.2 and 46.0.3 of both ckeditor5 and ckeditor5-clipboard.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CKEditor is susceptible to Cross-Site Scripting (XSS) through its clipboard package","id":"CVE-2025-58064","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":8,"n_references":2,"next":{"headline":"Flask App Builder has an Authentication Bypass vulnerability when using non AUTH_DB methods","id":"CVE-2025-58065"},"packages":[{"ecosystem":"npm","fixed":["45.2.2"],"introduced":["44.2.0"],"last_affected":[],"package":"@ckeditor/ckeditor5-clipboard","purl":null,"source":"GHSA-x9gp-vjh6-3wv6"},{"ecosystem":"npm","fixed":["45.2.2"],"introduced":["44.2.0"],"last_affected":[],"package":"@ckeditor/ckeditor5-clipboard","purl":"pkg:npm/%40ckeditor/ckeditor5-clipboard","source":"GHSA-x9gp-vjh6-3wv6"},{"ecosystem":"npm","fixed":["46.0.3"],"introduced":["46.0.0"],"last_affected":[],"package":"@ckeditor/ckeditor5-clipboard","purl":null,"source":"GHSA-x9gp-vjh6-3wv6"},{"ecosystem":"npm","fixed":["46.0.3"],"introduced":["46.0.0"],"last_affected":[],"package":"@ckeditor/ckeditor5-clipboard","purl":"pkg:npm/%40ckeditor/ckeditor5-clipboard","source":"GHSA-x9gp-vjh6-3wv6"},{"ecosystem":"npm","fixed":["45.2.2"],"introduced":["44.2.0"],"last_affected":[],"package":"ckeditor5","purl":null,"source":"GHSA-x9gp-vjh6-3wv6"},{"ecosystem":"npm","fixed":["45.2.2"],"introduced":["44.2.0"],"last_affected":[],"package":"ckeditor5","purl":"pkg:npm/ckeditor5","source":"GHSA-x9gp-vjh6-3wv6"},{"ecosystem":"npm","fixed":["46.0.3"],"introduced":["46.0.0"],"last_affected":[],"package":"ckeditor5","purl":null,"source":"GHSA-x9gp-vjh6-3wv6"},{"ecosystem":"npm","fixed":["46.0.3"],"introduced":["46.0.0"],"last_affected":[],"package":"ckeditor5","purl":"pkg:npm/ckeditor5","source":"GHSA-x9gp-vjh6-3wv6"}],"prev":{"headline":"CoreDNS: DNS Cache Pinning via etcd Lease ID Confusion","id":"CVE-2025-58063"},"products":["ckeditor5"],"published":"2025-09-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-09-04","vendors":["ckeditor"]},"summary":"Attackers can execute unauthorized JavaScript via malicious content in CKEditor 5 if specific plugins or configurations are enabled.","url":"https://insights.sbomify.com/CVE-2025-58064/"}