# CVE-2025-58064: CKEditor is susceptible to Cross-Site Scripting (XSS) through its clipboard package

> Attackers can execute unauthorized JavaScript via malicious content in CKEditor 5 if specific plugins or configurations are enabled.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Sep 2025
- **Updated:** 4 Sep 2025
- **Also known as:** GHSA-x9gp-vjh6-3wv6

## What is CVE-2025-58064?

CVE-2025-58064 is a low-severity cross-site scripting vulnerability in ckeditor5, published on 3 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. ckeditor5 and ckeditor5-clipboard versions 46.0.0 through 46.0.2 and 44.2.0 through 45.2.1 contain a Cross-Site Scripting (XSS) vulnerability. Ability to exploit could be triggered by a specific user action (leading to unauthorized JavaScript code execution) if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration. This vulnerability affects installations where the editor configuration meets one of the following criteria: the HTML embed plugin is enabled, or there is a custom plugin introducing an editable element where view RawElement is enabled. This issue is fixed in versions 45.2.2 and 46.0.3 of both ckeditor5 and ckeditor5-clipboard.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-58064?

8 open source packages ship an affected version, including @ckeditor/ckeditor5-clipboard and ckeditor5.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@ckeditor/ckeditor5-clipboard` | npm | From 44.2.0 | 45.2.2 |
| `@ckeditor/ckeditor5-clipboard` | npm | From 44.2.0 | 45.2.2 |
| `@ckeditor/ckeditor5-clipboard` | npm | From 46.0.0 | 46.0.3 |
| `@ckeditor/ckeditor5-clipboard` | npm | From 46.0.0 | 46.0.3 |
| `ckeditor5` | npm | From 44.2.0 | 45.2.2 |
| `ckeditor5` | npm | From 44.2.0 | 45.2.2 |
| `ckeditor5` | npm | From 46.0.0 | 46.0.3 |
| `ckeditor5` | npm | From 46.0.0 | 46.0.3 |

## How do I fix CVE-2025-58064?

Upgrade @ckeditor/ckeditor5-clipboard to a fixed version for your release line: 45.2.2 or 46.0.3.

## Is CVE-2025-58064 being exploited?

There is no known exploitation of CVE-2025-58064 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58064 and fix it if it is affected.

What it is: CVE-2025-58064 is a low-severity cross-site scripting vulnerability in ckeditor5, published on 3 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-58064 in the wild and no public exploit code.

Affected packages and fixed versions:
- @ckeditor/ckeditor5-clipboard (npm): affected from 44.2.0; fixed in 45.2.2
- @ckeditor/ckeditor5-clipboard (npm): affected from 44.2.0; fixed in 45.2.2
- @ckeditor/ckeditor5-clipboard (npm): affected from 46.0.0; fixed in 46.0.3
- @ckeditor/ckeditor5-clipboard (npm): affected from 46.0.0; fixed in 46.0.3
- ckeditor5 (npm): affected from 44.2.0; fixed in 45.2.2
- ckeditor5 (npm): affected from 44.2.0; fixed in 45.2.2
- ckeditor5 (npm): affected from 46.0.0; fixed in 46.0.3
- ckeditor5 (npm): affected from 46.0.0; fixed in 46.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58064/ (Markdown: https://insights.sbomify.com/CVE-2025-58064/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58064
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58064
- OSV: https://osv.dev/vulnerability/CVE-2025-58064

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58064/
Summaries are generated and may contain mistakes; the official description above is the record.
