# CVE-2025-58065: Flask App Builder has an Authentication Bypass vulnerability when using non AUTH_DB methods

> Attackers can reset passwords and create JWT tokens for disabled accounts when using non-database authentication methods in Flask-AppBuilder.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Sep 2025
- **Updated:** 11 Sep 2025
- **Also known as:** CLEANSTART-2026-AR41102, CLEANSTART-2026-KG57806, ECHO-7b59-8764-d50d, GHSA-765j-9r45-w2q2, MINI-jr9h-4f79-7mc8, MINI-r857-42r5-r26j, PYSEC-2026-1378, ROOT-APP-PYPI-CVE-2025-58065

## What is CVE-2025-58065?

CVE-2025-58065 is a medium-severity authentication bypass vulnerability in dpgaspar Flask-AppBuilder, published on 11 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Flask-AppBuilder is an application development framework. Prior to version 4.8.1, when Flask-AppBuilder is configured to use OAuth, LDAP, or other non-database authentication methods, the password reset endpoint remains registered and accessible, despite not being displayed in the user interface. This allows an enabled user to reset their password and be able to create JWT tokens even after the user is disabled on the authentication provider. Users should upgrade to Flask-AppBuilder version 4.8.1 or later to receive a fix. If immediate upgrade is not possible, manually disable password reset routes in the application configuration; implement additional access controls at the web server or proxy level to block access to the reset my password URL; and/or monitor for suspicious password reset attempts from disabled accounts.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2025-58065?

3 open source packages ship an affected version, including flask-appbuilder. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flask-appbuilder` | PyPI | All versions | 4.8.1 |
| `flask-appbuilder` | PyPI | All versions | 4.8.1 |
| `flask-appbuilder` | PyPI | All versions | 4.8.1 |

Products: Dpgaspar Flask-Appbuilder.

## How do I fix CVE-2025-58065?

Upgrade flask-appbuilder to 4.8.1 or later.

## Is CVE-2025-58065 being exploited?

There is no known exploitation of CVE-2025-58065 in the wild and no public exploit code.

## Other vulnerabilities in dpgaspar Flask-AppBuilder

- [CVE-2024-25128](https://insights.sbomify.com/CVE-2024-25128/): Flask-AppBuilder incorrect authentication when using auth type OpenID (critical 9.1)
- [CVE-2021-41265](https://insights.sbomify.com/CVE-2021-41265/): Improper Authentication in Flask-AppBuilder (high 8.1)
- [CVE-2023-29005](https://insights.sbomify.com/CVE-2023-29005/): No Rate Limiting on Login AUTH DB (high 7.5)
- [CVE-2021-32805](https://insights.sbomify.com/CVE-2021-32805/): URL Redirection to Untrusted Site ('Open Redirect') in Flask-AppBuilder (high 7.2)
- [CVE-2022-24776](https://insights.sbomify.com/CVE-2022-24776/): Open Redirect in Flask-AppBuilder (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58065 and fix it if it is affected.

What it is: CVE-2025-58065 is a medium-severity authentication bypass vulnerability in dpgaspar Flask-AppBuilder, published on 11 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-58065 in the wild and no public exploit code.

Affected packages and fixed versions:
- flask-appbuilder (PyPI): affected all versions; fixed in 4.8.1
- flask-appbuilder (PyPI): affected all versions; fixed in 4.8.1
- flask-appbuilder (PyPI): affected all versions; fixed in 4.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58065/ (Markdown: https://insights.sbomify.com/CVE-2025-58065/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58065
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58065
- OSV: https://osv.dev/vulnerability/CVE-2025-58065

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58065/
Summaries are generated and may contain mistakes; the official description above is the record.
