CVE-2025-58066 DoS Vulnerability in ntpd-rs
An attacker can cause a denial of service in ntpd-rs servers allowing non-NTS traffic by inducing a message storm between servers.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-58066?
CVE-2025-58066 is a medium-severity denial of service vulnerability in pendulum-project ntpd-rs, published on 29 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
nptd-rs is a tool for synchronizing your computer's clock, implementing the NTP and NTS protocols. In versions between 1.2.0 and 1.6.1 inclusive servers which allow non-NTS traffic are affected by a denial of service vulnerability, where an attacker can induce a message storm between two NTP servers running ntpd-rs. Client-only configurations are not affected. Affected users are recommended to upgrade to version 1.6.2 as soon as possible.
Weakness: CWE-406
Which versions are affected by CVE-2025-58066?
2 open source packages ship an affected version, including ntpd-rs.
| Package | Affected | Fixed in |
|---|---|---|
ntpd-rs crates.io | From 1.2.0 | 1.6.2 |
ntpd-rs crates.io | From 1.2.0 | 1.6.2 |
How do I fix CVE-2025-58066?
Upgrade ntpd-rs to 1.6.2 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-58066 being exploited?
There is no known exploitation of CVE-2025-58066 in the wild and no public exploit code.
Sources
Also known as DEBIAN-CVE-2025-58066, GHSA-4855-q42w-5vr4, UBUNTU-CVE-2025-58066.