{"answers":{"affected":"2 open source packages ship an affected version, including ntpd-rs.","exploited":"There is no known exploitation of CVE-2025-58066 in the wild and no public exploit code.","fix":"Upgrade ntpd-rs to 1.6.2 or later.","what":"CVE-2025-58066 is a medium-severity denial of service vulnerability in pendulum-project ntpd-rs, published on 29 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-58066 and fix it if it is affected.\n\nWhat it is: CVE-2025-58066 is a medium-severity denial of service vulnerability in pendulum-project ntpd-rs, published on 29 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-58066 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ntpd-rs (crates.io): affected from 1.2.0; fixed in 1.6.2\n- ntpd-rs (crates.io): affected from 1.2.0; fixed in 1.6.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-58066/ (Markdown: https://insights.sbomify.com/CVE-2025-58066/index.md)","id":"CVE-2025-58066","markdown":"https://insights.sbomify.com/CVE-2025-58066/index.md","name":"CVE-2025-58066","record":{"aliases":["DEBIAN-CVE-2025-58066","GHSA-4855-q42w-5vr4","UBUNTU-CVE-2025-58066"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"NTP time synchronization tool","requires_auth":"none","summary":"An attacker can cause a denial of service in ntpd-rs servers allowing non-NTS traffic by inducing a message storm between servers.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-406","name":"Insufficient Control of Network Message Volume (Network Amplification)"}],"description":"nptd-rs is a tool for synchronizing your computer's clock, implementing the NTP and NTS protocols. In versions between 1.2.0 and 1.6.1 inclusive servers which allow non-NTS traffic are affected by a denial of service vulnerability, where an attacker can induce a message storm between two NTP servers running ntpd-rs. Client-only configurations are not affected. Affected users are recommended to upgrade to version 1.6.2 as soon as possible.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"DoS Vulnerability in ntpd-rs","id":"CVE-2025-58066","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"Basecamp's Google Sign-In for Rails allowed redirects to protocol-relative URI","id":"CVE-2025-58067"},"packages":[{"ecosystem":"crates.io","fixed":["1.6.2"],"introduced":["1.2.0"],"last_affected":[],"package":"ntpd-rs","purl":null,"source":"GHSA-4855-q42w-5vr4"},{"ecosystem":"crates.io","fixed":["1.6.2"],"introduced":["1.2.0"],"last_affected":[],"package":"ntpd-rs","purl":"pkg:cargo/ntpd-rs","source":"GHSA-4855-q42w-5vr4"}],"prev":{"headline":"Flask App Builder has an Authentication Bypass vulnerability when using non AUTH_DB methods","id":"CVE-2025-58065"},"products":["ntpd-rs"],"published":"2025-08-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-09-02","vendors":["pendulum-project"]},"summary":"An attacker can cause a denial of service in ntpd-rs servers allowing non-NTS traffic by inducing a message storm between servers.","url":"https://insights.sbomify.com/CVE-2025-58066/"}