# CVE-2025-58066: DoS Vulnerability in ntpd-rs

> An attacker can cause a denial of service in ntpd-rs servers allowing non-NTS traffic by inducing a message storm between servers.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Aug 2025
- **Updated:** 2 Sep 2025
- **Also known as:** DEBIAN-CVE-2025-58066, GHSA-4855-q42w-5vr4, UBUNTU-CVE-2025-58066

## What is CVE-2025-58066?

CVE-2025-58066 is a medium-severity denial of service vulnerability in pendulum-project ntpd-rs, published on 29 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

nptd-rs is a tool for synchronizing your computer's clock, implementing the NTP and NTS protocols. In versions between 1.2.0 and 1.6.1 inclusive servers which allow non-NTS traffic are affected by a denial of service vulnerability, where an attacker can induce a message storm between two NTP servers running ntpd-rs. Client-only configurations are not affected. Affected users are recommended to upgrade to version 1.6.2 as soon as possible.

Weakness: CWE-406 (Insufficient Control of Network Message Volume (Network Amplification))

## Which versions are affected by CVE-2025-58066?

2 open source packages ship an affected version, including ntpd-rs.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ntpd-rs` | crates.io | From 1.2.0 | 1.6.2 |
| `ntpd-rs` | crates.io | From 1.2.0 | 1.6.2 |

## How do I fix CVE-2025-58066?

Upgrade ntpd-rs to 1.6.2 or later.

## Is CVE-2025-58066 being exploited?

There is no known exploitation of CVE-2025-58066 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58066 and fix it if it is affected.

What it is: CVE-2025-58066 is a medium-severity denial of service vulnerability in pendulum-project ntpd-rs, published on 29 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-58066 in the wild and no public exploit code.

Affected packages and fixed versions:
- ntpd-rs (crates.io): affected from 1.2.0; fixed in 1.6.2
- ntpd-rs (crates.io): affected from 1.2.0; fixed in 1.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58066/ (Markdown: https://insights.sbomify.com/CVE-2025-58066/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58066
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58066
- OSV: https://osv.dev/vulnerability/CVE-2025-58066

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58066/
Summaries are generated and may contain mistakes; the official description above is the record.
