# CVE-2025-58067: Basecamp's Google Sign-In for Rails allowed redirects to protocol-relative URI


- **Severity:** Medium 4.2 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 29 Aug 2025
- **Updated:** 2 Sep 2025
- **Also known as:** GHSA-5jch-xhw4-r43v

## What is CVE-2025-58067?

CVE-2025-58067 is a medium-severity vulnerability in basecamp google_sign_in, published on 29 Aug 2025. 

### Official description

Basecamp's Google Sign-In adds Google sign-in to Rails applications. Prior to version 1.3.1, it is possible to redirect a user to another origin if the "proceed_to" value in the session store is set to a protocol-relative URL. Normally the value of this URL is only written and read by the library or the calling application. However, it may be possible to set this session value from a malicious site with a form submission. Any Rails applications using the google_sign_in gem may be vulnerable, if this vector can be chained with another attack that is able to modify the OAuth2 request parameters. This issue has been patched in version 1.3.1. There are no workarounds.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2025-58067?

2 open source packages ship an affected version, including google_sign_in.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `google_sign_in` | RubyGems | All versions | 1.3.1 |
| `google_sign_in` | RubyGems | All versions | 1.3.1 |

## How do I fix CVE-2025-58067?

Upgrade google_sign_in to 1.3.1 or later.

## Is CVE-2025-58067 being exploited?

There is no known exploitation of CVE-2025-58067 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58067 and fix it if it is affected.

What it is: CVE-2025-58067 is a medium-severity vulnerability in basecamp google_sign_in, published on 29 Aug 2025. 
Exploitation: There is no known exploitation of CVE-2025-58067 in the wild and no public exploit code.

Affected packages and fixed versions:
- google_sign_in (RubyGems): affected all versions; fixed in 1.3.1
- google_sign_in (RubyGems): affected all versions; fixed in 1.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58067/ (Markdown: https://insights.sbomify.com/CVE-2025-58067/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58067
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58067
- OSV: https://osv.dev/vulnerability/CVE-2025-58067

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58067/
Summaries are generated and may contain mistakes; the official description above is the record.
