# CVE-2025-58068: Eventlet affected by HTTP request smuggling in unparsed trailers

> Attackers can exploit HTTP request smuggling in Eventlet to bypass security controls, attack users, and poison caches.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Aug 2025
- **Updated:** 3 Nov 2025
- **Also known as:** DEBIAN-CVE-2025-58068, DLA-4289-1, ECHO-0062-6c67-8811, GHSA-hw6f-rjfj-j7j7, OESA-2025-2199, OESA-2025-2200, OESA-2025-2201, OESA-2025-2202, OESA-2025-2203, OESA-2025-2232, PYSEC-2026-1350, RHSA-2026:1959, ROOT-APP-PYPI-CVE-2025-58068, SUSE-SU-2025:03051-1, SUSE-SU-2025:03202-1, UBUNTU-CVE-2025-58068, USN-7772-1, openSUSE-SU-2025:15507-1

## What is CVE-2025-58068?

CVE-2025-58068 is a medium-severity vulnerability in eventlet, published on 29 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Eventlet is a concurrent networking library for Python. Prior to version 0.40.3, the Eventlet WSGI parser is vulnerable to HTTP Request Smuggling due to improper handling of HTTP trailer sections. This vulnerability could enable attackers to, bypass front-end security controls, launch targeted attacks against active site users, and poison web caches. This problem has been patched in Eventlet 0.40.3 by dropping trailers which is a breaking change if a backend behind eventlet.wsgi proxy requires trailers. A workaround involves not using eventlet.wsgi facing untrusted clients.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2025-58068?

3 open source packages ship an affected version, including eventlet. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `eventlet` | PyPI | All versions | 0.40.3 |
| `eventlet` | PyPI | All versions | 0.40.3 |
| `eventlet` | PyPI | All versions | 0.40.3 |
| `python-eventlet` | Red Hat:openstack:18.0::el9 | All versions | 0:0.33.1-7.el9ost |
| `python3-eventlet` | Red Hat:openstack:18.0::el9 | All versions | 0:0.33.1-7.el9ost |
| `python-eventlet` | SUSE:Linux Enterprise Module for Package Hub 15 SP6 | All versions | 0.26.1-150300.3.3.1 |
| `python-eventlet` | SUSE:Linux Enterprise Module for Package Hub 15 SP7 | All versions | 0.26.1-150300.3.3.1 |
| `python-eventlet` | SUSE:Linux Enterprise Module for Python 3 15 SP6 | All versions | 0.33.3-150400.5.6.1 |
| `python-eventlet` | SUSE:Linux Enterprise Module for Python 3 15 SP7 | All versions | 0.33.3-150400.5.6.1 |
| `python-eventlet` | openSUSE:Leap 15.6 | All versions | 0.33.3-150400.5.6.1 |
| `python-eventlet` | openSUSE:Tumbleweed | All versions | 0.40.3-1.1 |

Products: Eventlet Eventlet.

## How do I fix CVE-2025-58068?

Upgrade eventlet to 0.40.3 or later.

## Is CVE-2025-58068 being exploited?

There is no known exploitation of CVE-2025-58068 in the wild and no public exploit code.

## Other vulnerabilities in eventlet

- [CVE-2021-21419](https://insights.sbomify.com/CVE-2021-21419/): Improper Handling of Highly Compressed Data (Data Amplification) and Memory Allocation with Excessive Size Value in eventlet (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58068 and fix it if it is affected.

What it is: CVE-2025-58068 is a medium-severity vulnerability in eventlet, published on 29 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-58068 in the wild and no public exploit code.

Affected packages and fixed versions:
- eventlet (PyPI): affected all versions; fixed in 0.40.3
- eventlet (PyPI): affected all versions; fixed in 0.40.3
- eventlet (PyPI): affected all versions; fixed in 0.40.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58068/ (Markdown: https://insights.sbomify.com/CVE-2025-58068/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58068
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58068
- OSV: https://osv.dev/vulnerability/CVE-2025-58068

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58068/
Summaries are generated and may contain mistakes; the official description above is the record.
