CVE-2025-58075 Arbitrary Mattermost Team can be joined by manipulating the SAML RelayState
Attackers can join arbitrary Mattermost teams by manipulating SAML RelayState, bypassing team membership restrictions and accessing private data.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-58075?
CVE-2025-58075 is a high-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 16 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 10.11.x <= 10.11.1, 10.10.x <= 10.10.2, 10.5.x <= 10.5.10 fail to verify a user has permission to join a Mattermost team using the original invite token which allows any attacked to join any team on a Mattermost server regardless of restrictions via manipulating the RelayState
Weakness: CWE-862
Which versions are affected by CVE-2025-58075?
12 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 10.10.0 | 10.10.3 |
github.com/mattermost/mattermost-server Go | From 10.10.0 | 10.10.3 |
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.2 |
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.2 |
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.11 |
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.11 |
6 more packages
github.com/mattermost/mattermost-server Go | From 10.5.0+incompatible | 10.5.11+incompatible, 10.10.3+incompatible, 10.11.2+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250815100400-2d5cdc6e217e |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250815100400-2d5cdc6e217e |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-58075?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.10.3, 10.11.2, 10.5.11 or 10.5.11+incompatible.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-58075 being exploited?
There is no known exploitation of CVE-2025-58075 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-r6qj-894f-5hr2, GO-2025-4035.