CVE-2025-58098 Apache HTTP Server: Server Side Includes adds query string to #exec cmd=...

High 8.3 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2025-58098?

CVE-2025-58098 is a high-severity vulnerability in Apache Http Server, published on 5 Dec 2025.

Official description

Apache HTTP Server 2.4.65 and earlier with Server Side Includes (SSI) enabled and mod_cgid (but not mod_cgi) passes the shell-escaped query string to #exec cmd="..." directives.

This issue affects Apache HTTP Server before 2.4.66.

Users are recommended to upgrade to version 2.4.66, which fixes the issue.

Weakness: CWE-201

Which versions are affected by CVE-2025-58098?

1 open source package ship an affected version, including apache. It affects 1 product.

PackageAffectedFixed in
apache BitnamiAll versions2.4.66
Linux distribution packages (39)
httpd Red Hat:enterprise_linux_eus:10.0All versions0:2.4.63-1.el10_0.3
httpd-core Red Hat:enterprise_linux_eus:10.0All versions0:2.4.63-1.el10_0.3
httpd-core-debuginfo Red Hat:enterprise_linux_eus:10.0All versions0:2.4.63-1.el10_0.3
httpd-debuginfo Red Hat:enterprise_linux_eus:10.0All versions0:2.4.63-1.el10_0.3
httpd-debugsource Red Hat:enterprise_linux_eus:10.0All versions0:2.4.63-1.el10_0.3
httpd-devel Red Hat:enterprise_linux_eus:10.0All versions0:2.4.63-1.el10_0.3
httpd-filesystem Red Hat:enterprise_linux_eus:10.0All versions0:2.4.63-1.el10_0.3
httpd-manual Red Hat:enterprise_linux_eus:10.0All versions0:2.4.63-1.el10_0.3
httpd-tools Red Hat:enterprise_linux_eus:10.0All versions0:2.4.63-1.el10_0.3
httpd-tools-debuginfo Red Hat:enterprise_linux_eus:10.0All versions0:2.4.63-1.el10_0.3
mod_ldap Red Hat:enterprise_linux_eus:10.0All versions0:2.4.63-1.el10_0.3
mod_ldap-debuginfo Red Hat:enterprise_linux_eus:10.0All versions0:2.4.63-1.el10_0.3
mod_lua Red Hat:enterprise_linux_eus:10.0All versions0:2.4.63-1.el10_0.3
mod_lua-debuginfo Red Hat:enterprise_linux_eus:10.0All versions0:2.4.63-1.el10_0.3
mod_proxy_html Red Hat:enterprise_linux_eus:10.0All versions1:2.4.63-1.el10_0.3
mod_proxy_html-debuginfo Red Hat:enterprise_linux_eus:10.0All versions1:2.4.63-1.el10_0.3
mod_session Red Hat:enterprise_linux_eus:10.0All versions0:2.4.63-1.el10_0.3
mod_session-debuginfo Red Hat:enterprise_linux_eus:10.0All versions0:2.4.63-1.el10_0.3
mod_ssl Red Hat:enterprise_linux_eus:10.0All versions1:2.4.63-1.el10_0.3
mod_ssl-debuginfo Red Hat:enterprise_linux_eus:10.0All versions1:2.4.63-1.el10_0.3
httpd Red Hat:rhel_e4s:9.0::appstreamAll versions0:2.4.51-7.el9_0.11
httpd-debuginfo Red Hat:rhel_e4s:9.0::appstreamAll versions0:2.4.51-7.el9_0.11
httpd-debugsource Red Hat:rhel_e4s:9.0::appstreamAll versions0:2.4.51-7.el9_0.11
httpd-devel Red Hat:rhel_e4s:9.0::appstreamAll versions0:2.4.51-7.el9_0.11
httpd-filesystem Red Hat:rhel_e4s:9.0::appstreamAll versions0:2.4.51-7.el9_0.11
httpd-manual Red Hat:rhel_e4s:9.0::appstreamAll versions0:2.4.51-7.el9_0.11
httpd-tools Red Hat:rhel_e4s:9.0::appstreamAll versions0:2.4.51-7.el9_0.11
httpd-tools-debuginfo Red Hat:rhel_e4s:9.0::appstreamAll versions0:2.4.51-7.el9_0.11
mod_ldap Red Hat:rhel_e4s:9.0::appstreamAll versions0:2.4.51-7.el9_0.11
mod_ldap-debuginfo Red Hat:rhel_e4s:9.0::appstreamAll versions0:2.4.51-7.el9_0.11
mod_lua Red Hat:rhel_e4s:9.0::appstreamAll versions0:2.4.51-7.el9_0.11
mod_lua-debuginfo Red Hat:rhel_e4s:9.0::appstreamAll versions0:2.4.51-7.el9_0.11
mod_proxy_html Red Hat:rhel_e4s:9.0::appstreamAll versions1:2.4.51-7.el9_0.11
mod_proxy_html-debuginfo Red Hat:rhel_e4s:9.0::appstreamAll versions1:2.4.51-7.el9_0.11
mod_session Red Hat:rhel_e4s:9.0::appstreamAll versions0:2.4.51-7.el9_0.11
mod_session-debuginfo Red Hat:rhel_e4s:9.0::appstreamAll versions0:2.4.51-7.el9_0.11
mod_ssl Red Hat:rhel_e4s:9.0::appstreamAll versions1:2.4.51-7.el9_0.11
mod_ssl-debuginfo Red Hat:rhel_e4s:9.0::appstreamAll versions1:2.4.51-7.el9_0.11
httpd Red Hat:rhel_e4s:9.2::appstreamAll versions0:2.4.53-11.el9_2.14

Products include Apache Http Server.

How do I fix CVE-2025-58098?

Upgrade apache to 2.4.66 or later.

Is CVE-2025-58098 being exploited?

There is no known exploitation of CVE-2025-58098 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

All Apache Http Server vulnerabilities

Sources

Also known as ALPINE-CVE-2025-58098, AZL-71860, AZL-71867, BELL-CVE-2025-58098, BIT-apache-2025-58098, CLSA-2025-1767004508 and 19 more.

Is CVE-2025-58098 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free