# CVE-2025-58098: Apache HTTP Server: Server Side Includes adds query string to #exec cmd=...


- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 5 Dec 2025
- **Updated:** 26 Feb 2026
- **Also known as:** ALPINE-CVE-2025-58098, AZL-71860, AZL-71867, BELL-CVE-2025-58098, BIT-apache-2025-58098, CLSA-2025-1767004508, CLSA-2025-1767027096, CLSA-2026-1767609927, CLSA-2026-1767613214, CLSA-2026-1767800942, CLSA-2026-1767949942, CLSA-2026-1767950193, CLSA-2026-1767970357, CLSA-2026-1781253209, DEBIAN-CVE-2025-58098, GHSA-4m29-g52g-c6qc, MINI-33v8-7v9w-g6xf, RHSA-2026:0074, RHSA-2026:0075, RHSA-2026:0090, RHSA-2026:0095, RHSA-2026:0139, RHSA-2026:0141, RHSA-2026:0171, UBUNTU-CVE-2025-58098

## What is CVE-2025-58098?

CVE-2025-58098 is a high-severity vulnerability in Apache Http Server, published on 5 Dec 2025. 

### Official description

Apache HTTP Server 2.4.65 and earlier with Server Side Includes (SSI) enabled and mod_cgid (but not mod_cgi) passes the shell-escaped query string to #exec cmd="..." directives.

This issue affects Apache HTTP Server before 2.4.66.

Users are recommended to upgrade to version 2.4.66, which fixes the issue.

Weakness: CWE-201 (Insertion of Sensitive Information Into Sent Data)

## Which versions are affected by CVE-2025-58098?

1 open source package ship an affected version, including apache. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache` | Bitnami | All versions | 2.4.66 |
| `httpd` | Red Hat:enterprise_linux_eus:10.0 | All versions | 0:2.4.63-1.el10_0.3 |
| `httpd-core` | Red Hat:enterprise_linux_eus:10.0 | All versions | 0:2.4.63-1.el10_0.3 |
| `httpd-core-debuginfo` | Red Hat:enterprise_linux_eus:10.0 | All versions | 0:2.4.63-1.el10_0.3 |
| `httpd-debuginfo` | Red Hat:enterprise_linux_eus:10.0 | All versions | 0:2.4.63-1.el10_0.3 |
| `httpd-debugsource` | Red Hat:enterprise_linux_eus:10.0 | All versions | 0:2.4.63-1.el10_0.3 |
| `httpd-devel` | Red Hat:enterprise_linux_eus:10.0 | All versions | 0:2.4.63-1.el10_0.3 |
| `httpd-filesystem` | Red Hat:enterprise_linux_eus:10.0 | All versions | 0:2.4.63-1.el10_0.3 |
| `httpd-manual` | Red Hat:enterprise_linux_eus:10.0 | All versions | 0:2.4.63-1.el10_0.3 |
| `httpd-tools` | Red Hat:enterprise_linux_eus:10.0 | All versions | 0:2.4.63-1.el10_0.3 |
| `httpd-tools-debuginfo` | Red Hat:enterprise_linux_eus:10.0 | All versions | 0:2.4.63-1.el10_0.3 |
| `mod_ldap` | Red Hat:enterprise_linux_eus:10.0 | All versions | 0:2.4.63-1.el10_0.3 |
| `mod_ldap-debuginfo` | Red Hat:enterprise_linux_eus:10.0 | All versions | 0:2.4.63-1.el10_0.3 |
| `mod_lua` | Red Hat:enterprise_linux_eus:10.0 | All versions | 0:2.4.63-1.el10_0.3 |
| `mod_lua-debuginfo` | Red Hat:enterprise_linux_eus:10.0 | All versions | 0:2.4.63-1.el10_0.3 |
| `mod_proxy_html` | Red Hat:enterprise_linux_eus:10.0 | All versions | 1:2.4.63-1.el10_0.3 |
| `mod_proxy_html-debuginfo` | Red Hat:enterprise_linux_eus:10.0 | All versions | 1:2.4.63-1.el10_0.3 |
| `mod_session` | Red Hat:enterprise_linux_eus:10.0 | All versions | 0:2.4.63-1.el10_0.3 |
| `mod_session-debuginfo` | Red Hat:enterprise_linux_eus:10.0 | All versions | 0:2.4.63-1.el10_0.3 |
| `mod_ssl` | Red Hat:enterprise_linux_eus:10.0 | All versions | 1:2.4.63-1.el10_0.3 |
| `mod_ssl-debuginfo` | Red Hat:enterprise_linux_eus:10.0 | All versions | 1:2.4.63-1.el10_0.3 |
| `httpd` | Red Hat:rhel_e4s:9.0::appstream | All versions | 0:2.4.51-7.el9_0.11 |
| `httpd-debuginfo` | Red Hat:rhel_e4s:9.0::appstream | All versions | 0:2.4.51-7.el9_0.11 |
| `httpd-debugsource` | Red Hat:rhel_e4s:9.0::appstream | All versions | 0:2.4.51-7.el9_0.11 |
| `httpd-devel` | Red Hat:rhel_e4s:9.0::appstream | All versions | 0:2.4.51-7.el9_0.11 |
| `httpd-filesystem` | Red Hat:rhel_e4s:9.0::appstream | All versions | 0:2.4.51-7.el9_0.11 |
| `httpd-manual` | Red Hat:rhel_e4s:9.0::appstream | All versions | 0:2.4.51-7.el9_0.11 |
| `httpd-tools` | Red Hat:rhel_e4s:9.0::appstream | All versions | 0:2.4.51-7.el9_0.11 |
| `httpd-tools-debuginfo` | Red Hat:rhel_e4s:9.0::appstream | All versions | 0:2.4.51-7.el9_0.11 |
| `mod_ldap` | Red Hat:rhel_e4s:9.0::appstream | All versions | 0:2.4.51-7.el9_0.11 |
| `mod_ldap-debuginfo` | Red Hat:rhel_e4s:9.0::appstream | All versions | 0:2.4.51-7.el9_0.11 |
| `mod_lua` | Red Hat:rhel_e4s:9.0::appstream | All versions | 0:2.4.51-7.el9_0.11 |
| `mod_lua-debuginfo` | Red Hat:rhel_e4s:9.0::appstream | All versions | 0:2.4.51-7.el9_0.11 |
| `mod_proxy_html` | Red Hat:rhel_e4s:9.0::appstream | All versions | 1:2.4.51-7.el9_0.11 |
| `mod_proxy_html-debuginfo` | Red Hat:rhel_e4s:9.0::appstream | All versions | 1:2.4.51-7.el9_0.11 |
| `mod_session` | Red Hat:rhel_e4s:9.0::appstream | All versions | 0:2.4.51-7.el9_0.11 |
| `mod_session-debuginfo` | Red Hat:rhel_e4s:9.0::appstream | All versions | 0:2.4.51-7.el9_0.11 |
| `mod_ssl` | Red Hat:rhel_e4s:9.0::appstream | All versions | 1:2.4.51-7.el9_0.11 |
| `mod_ssl-debuginfo` | Red Hat:rhel_e4s:9.0::appstream | All versions | 1:2.4.51-7.el9_0.11 |
| `httpd` | Red Hat:rhel_e4s:9.2::appstream | All versions | 0:2.4.53-11.el9_2.14 |

Products: Apache Http Server.

## How do I fix CVE-2025-58098?

Upgrade apache to 2.4.66 or later.

## Is CVE-2025-58098 being exploited?

There is no known exploitation of CVE-2025-58098 in the wild and no public exploit code.

Public exploit code:

- #exec cmd=... (CVE-2025-58098) argument injection (github_poc): https://github.com/dhmosfunk/CVE-2025-58098

## Other vulnerabilities in Apache Http Server

- [CVE-2021-42013](https://insights.sbomify.com/CVE-2021-42013/): Apache HTTP Server Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2024-38475](https://insights.sbomify.com/CVE-2024-38475/): Apache HTTP Server Improper Escaping of Output (critical 9.1, exploited in the wild)
- [CVE-2021-40438](https://insights.sbomify.com/CVE-2021-40438/): Apache HTTP Server-Side Request Forgery (SSRF) (critical 9.0, exploited in the wild)
- [CVE-2019-0211](https://insights.sbomify.com/CVE-2019-0211/): Apache HTTP Server Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2021-41773](https://insights.sbomify.com/CVE-2021-41773/): Apache HTTP Server Path Traversal (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58098 and fix it if it is affected.

What it is: CVE-2025-58098 is a high-severity vulnerability in Apache Http Server, published on 5 Dec 2025. 
Exploitation: There is no known exploitation of CVE-2025-58098 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache (Bitnami): affected all versions; fixed in 2.4.66

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58098/ (Markdown: https://insights.sbomify.com/CVE-2025-58098/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58098
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58098
- OSV: https://osv.dev/vulnerability/CVE-2025-58098

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58098/
Summaries are generated and may contain mistakes; the official description above is the record.
