CVE-2025-58130 Apache Fineract: Server Key not masked

Critical 9.1 Published Updated

Apache Fineract fails to mask server keys, potentially exposing sensitive credentials to attackers.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-58130?

CVE-2025-58130 is a critical vulnerability in Apache Fineract, published on 12 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Insufficiently Protected Credentials vulnerability in Apache Fineract.

This issue affects Apache Fineract: through 1.11.0. The issue is fixed in version 1.12.1.

Users are encouraged to upgrade to version 1.13.0, the latest release.

Weakness: CWE-522

Which versions are affected by CVE-2025-58130?

It affects 1 product.

Products include Apache Fineract.

How do I fix CVE-2025-58130?

No fix has been published for CVE-2025-58130 yet. Limit exposure of the affected software until one is available.

Is CVE-2025-58130 being exploited?

There is no known exploitation of CVE-2025-58130 in the wild and no public exploit code.

Sources

Also known as GHSA-rgjm-h5hc-fhwv.

Is CVE-2025-58130 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free