{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-58130 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-58130 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-58130 is a critical vulnerability in Apache Fineract, published on 12 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-58130 and fix it if it is affected.\n\nWhat it is: CVE-2025-58130 is a critical vulnerability in Apache Fineract, published on 12 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-58130 in the wild and no public exploit code.\n\nAffected product: Apache Fineract. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-58130/ (Markdown: https://insights.sbomify.com/CVE-2025-58130/index.md)","id":"CVE-2025-58130","markdown":"https://insights.sbomify.com/CVE-2025-58130/index.md","name":"CVE-2025-58130","record":{"aliases":["GHSA-rgjm-h5hc-fhwv"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Financial core banking","requires_auth":"none","summary":"Apache Fineract fails to mask server keys, potentially exposing sensitive credentials to attackers.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"fineract","vendor":"apache"}],"cvss":{"score":9.1,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-522","name":"Insufficiently Protected Credentials"}],"description":"Insufficiently Protected Credentials vulnerability in Apache Fineract.\n\nThis issue affects Apache Fineract: through 1.11.0. The issue is fixed in version 1.12.1.\n\nUsers are encouraged to upgrade to version 1.13.0, the latest release.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Apache Fineract: Server Key not masked","id":"CVE-2025-58130","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"information_disclosure","year":"2025"},"n_packages":0,"n_references":1,"next":{"headline":"Zoom Workplace VDI Plugin macOS Universal installer for VMware Horizon - Race Condition","id":"CVE-2025-58131"},"packages":[],"prev":{"headline":"Lack of TLS validation in plugin Dell Powerscale on Checkmk Exchange","id":"CVE-2025-58127"},"products":["Apache Fineract"],"published":"2025-12-12","related":[{"cvss_score":9.9,"headline":"SQL injection in Apache Fineract","id":"CVE-2024-23538","kev_date_added":null,"published":"2024-03-29"},{"cvss_score":9.8,"headline":"SQL injection in Apache Fineract","id":"CVE-2018-11800","kev_date_added":null,"published":"2019-06-11"},{"cvss_score":9.8,"headline":"SQL injection in Apache Fineract","id":"CVE-2018-11801","kev_date_added":null,"published":"2019-06-11"},{"cvss_score":9.8,"headline":"SQL injection in Apache Fineract","id":"CVE-2018-1290","kev_date_added":null,"published":"2018-04-20"},{"cvss_score":9.4,"headline":"Apache Fineract: SQL injection vulnerabilities in offices API endpoint","id":"CVE-2024-32838","kev_date_added":null,"published":"2025-02-12"},{"cvss_score":8.8,"headline":"Apache Fineract: SQL injection in runreports endpoint","id":"CVE-2026-35152","kev_date_added":null,"published":"2026-07-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-12-12","vendors":["Apache Software Foundation"]},"summary":"Apache Fineract fails to mask server keys, potentially exposing sensitive credentials to attackers.","url":"https://insights.sbomify.com/CVE-2025-58130/"}