CVE-2025-58136 Apache Traffic Server: A simple legitimate POST request causes a crash

High 7.5 Published Updated

A bug in POST request handling causes a crash, allowing attackers to disrupt service availability in Apache Traffic Server.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-58136?

CVE-2025-58136 is a high-severity denial of service vulnerability in Apache Traffic Server, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A bug in POST request handling causes a crash under a certain condition.

This issue affects Apache Traffic Server: from 10.0.0 through 10.1.1, from 9.0.0 through 9.2.12.

Users are recommended to upgrade to version 10.1.2 or 9.2.13, which fix the issue.

A workaround for older versions is to set proxy.config.http.request_buffer_enabled to 0 (the default value is 0).

Weakness: CWE-670

Which versions are affected by CVE-2025-58136?

It affects 1 product.

Products include Apache Traffic Server.

How do I fix CVE-2025-58136?

Upgrade to a fixed version.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-58136 being exploited?

There is no known exploitation of CVE-2025-58136 in the wild and no public exploit code.

All Apache Traffic Server vulnerabilities

Sources

Also known as DEBIAN-CVE-2025-58136, GHSA-wvq7-4f7c-q7wc, OESA-2026-2384, UBUNTU-CVE-2025-58136.

Is CVE-2025-58136 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free