CVE-2025-58137 Apache Fineract: IDOR via self-service API

High 8.1 Published Updated

Attackers can bypass authorization in Apache Fineract's self-service API to access or modify other users' data.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-58137?

CVE-2025-58137 is a high-severity missing authorization vulnerability in Apache Fineract, published on 12 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Authorization Bypass Through User-Controlled Key vulnerability in Apache Fineract.

This issue affects Apache Fineract: through 1.11.0. The issue is fixed in version 1.12.1.

Users are encouraged to upgrade to version 1.13.0, the latest release.

Weakness: CWE-639

Which versions are affected by CVE-2025-58137?

It affects 1 product.

Products include Apache Fineract.

How do I fix CVE-2025-58137?

No fix has been published for CVE-2025-58137 yet. Limit exposure of the affected software until one is available.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-58137 being exploited?

There is no known exploitation of CVE-2025-58137 in the wild and no public exploit code.

Sources

Also known as GHSA-5rq6-3978-369w.

Is CVE-2025-58137 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free