# CVE-2025-58157: gnark affected by denial of service when computing scalar multiplication using fake-GLV algorithm

> An attacker can cause a denial of service in the gnark library by providing inputs that prevent the fake-GLV scalar multiplication algorithm from converging.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Aug 2025
- **Updated:** 2 Sep 2025
- **Also known as:** GHSA-9fvj-xqr2-xwg8, GO-2025-3929

## What is CVE-2025-58157?

CVE-2025-58157 is a high-severity denial of service vulnerability in Consensys gnark, published on 29 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

gnark is a zero-knowledge proof system framework. In version 0.12.0, there is a potential denial of service vulnerability when computing scalar multiplication is using the fake-GLV algorithm. This is because the algorithm didn't converge quickly enough for some of the inputs. This issue has been patched in version 0.13.0.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2025-58157?

3 open source packages ship an affected version, including github.com/consensys/gnark. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/consensys/gnark` | Go | All versions | 0.13.0 |
| `github.com/consensys/gnark` | Go | From 0.12.0 | 0.13.0 |
| `github.com/consensys/gnark` | Go | From 0.12.0 | 0.13.0 |

Products: Consensys Gnark.

## How do I fix CVE-2025-58157?

Upgrade github.com/consensys/gnark to 0.13.0 or later.

## Is CVE-2025-58157 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-58157 exists.

## Other vulnerabilities in Consensys gnark

- [CVE-2025-57801](https://insights.sbomify.com/CVE-2025-57801/): gnark is vulnerable to signature malleability in EdDSA and ECDSA due to missing scalar checks (high 8.6)
- [CVE-2023-44378](https://insights.sbomify.com/CVE-2023-44378/): gnark vulnerable to unsoundness in variable comparison/non-unique binary decomposition (high 7.1)
- [CVE-2024-50354](https://insights.sbomify.com/CVE-2024-50354/): Out-of-memory during deserialization with crafted inputs (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58157 and fix it if it is affected.

What it is: CVE-2025-58157 is a high-severity denial of service vulnerability in Consensys gnark, published on 29 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-58157 exists.

Affected packages and fixed versions:
- github.com/consensys/gnark (Go): affected all versions; fixed in 0.13.0
- github.com/consensys/gnark (Go): affected from 0.12.0; fixed in 0.13.0
- github.com/consensys/gnark (Go): affected from 0.12.0; fixed in 0.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58157/ (Markdown: https://insights.sbomify.com/CVE-2025-58157/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58157
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58157
- OSV: https://osv.dev/vulnerability/CVE-2025-58157

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58157/
Summaries are generated and may contain mistakes; the official description above is the record.
