# CVE-2025-58161: MobSF Path Traversal in GET /download/<filename> using absolute filenames

> An authenticated attacker can download files outside the intended directory via path traversal in MobSF, leading to data leakage.

- **Severity:** Low 1.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Sep 2025
- **Updated:** 2 Sep 2025
- **Also known as:** GHSA-ccc3-fvfx-mw3v, PYSEC-2026-1672

## What is CVE-2025-58161?

CVE-2025-58161 is a low-severity path traversal vulnerability in Mobile-Security-Framework-MobSF, published on 2 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

MobSF is a mobile application security testing tool used. In version 4.4.0, the GET /download/ route uses string path verification via os.path.commonprefix, which allows an authenticated user to download files outside the DWD_DIR download directory from "neighboring" directories whose absolute paths begin with the same prefix as DWD_DIR (e.g., .../downloads_bak, .../downloads.old). This is a Directory Traversal (escape) leading to a data leak. This issue has been patched in version 4.4.1.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-58161?

3 open source packages ship an affected version, including mobsf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mobsf` | PyPI | All versions | 4.4.1 |
| `mobsf` | PyPI | All versions | 4.4.1 |
| `mobsf` | PyPI | All versions | 4.4.1 |

Products: Opensecurity Mobile Security Framework.

## How do I fix CVE-2025-58161?

Upgrade mobsf to 4.4.1 or later.

## Is CVE-2025-58161 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-58161 exists.

## Other vulnerabilities in Mobile-Security-Framework-MobSF

- [CVE-2025-46335](https://insights.sbomify.com/CVE-2025-46335/): Mobile Security Framework (MobSF) Allows Stored Cross Site Scripting (XSS) via malicious SVG Icon Upload (high 8.6)
- [CVE-2025-24805](https://insights.sbomify.com/CVE-2025-24805/): Local Privilege Escalation in MobSF (high 8.5)
- [CVE-2025-24803](https://insights.sbomify.com/CVE-2025-24803/): Stored Cross-Site Scripting (XSS) in MobSF (high 8.4)
- [CVE-2026-24490](https://insights.sbomify.com/CVE-2026-24490/): MobSF has Stored XSS via Manifest Analysis - Dialer Code Host Field (high 8.1)
- [CVE-2024-53999](https://insights.sbomify.com/CVE-2024-53999/): Mobile Security Framework (MobSF) Stored Cross-Site Scripting Vulnerability in "Diff or Compare" Functionality (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58161 and fix it if it is affected.

What it is: CVE-2025-58161 is a low-severity path traversal vulnerability in Mobile-Security-Framework-MobSF, published on 2 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-58161 exists.

Affected packages and fixed versions:
- mobsf (PyPI): affected all versions; fixed in 4.4.1
- mobsf (PyPI): affected all versions; fixed in 4.4.1
- mobsf (PyPI): affected all versions; fixed in 4.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58161/ (Markdown: https://insights.sbomify.com/CVE-2025-58161/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58161
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58161
- OSV: https://osv.dev/vulnerability/CVE-2025-58161

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58161/
Summaries are generated and may contain mistakes; the official description above is the record.
