# CVE-2025-58163: FreeScout's deserialization of untrusted data can lead to Remote Code Execution

> Authenticated attackers with APP_KEY knowledge can achieve remote code execution in FreeScout via unsafe deserialization in decryption logic.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 3 Sep 2025
- **Updated:** 3 Sep 2025
- **Also known as:** GHSA-j94w-q9gj-c37g

## What is CVE-2025-58163?

CVE-2025-58163 is a high-severity unsafe deserialization vulnerability in freescout-help-desk freescout, published on 3 Sep 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

FreeScout is a free help desk and shared inbox built with PHP's Laravel framework. Versions 1.8.185 and earlier contain a deserialization of untrusted data vulnerability that allows authenticated attackers with knowledge of the application's APP_KEY to achieve remote code execution. The vulnerability is exploited via endpoint, e.g.: `/help/{mailbox_id}/auth/{customer_id}/{hash}/{timestamp}` where the `customer_id` and `timestamp` parameters are processed through the decrypt function in `app/Helper.php` without proper validation. The code decrypts using Laravel's built-in encryption functions, which subsequently deserialize the decrypted payload without sanitization, allowing attackers to craft malicious serialized PHP objects using classes to trigger arbitrary command execution. This is fixed in version 1.8.186.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-58163?

It affects 1 product.


Products: Freescout Freescout.

## How do I fix CVE-2025-58163?

No fix has been published for CVE-2025-58163 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-58163 being exploited?

There is no known exploitation of CVE-2025-58163 in the wild and no public exploit code.

## Other vulnerabilities in freescout-help-desk freescout

- [CVE-2026-28289](https://insights.sbomify.com/CVE-2026-28289/): FreeScout 1.8.206 Patch Bypass for CVE-2026-27636 via Zero-Width Space Character Leads to Remote Code Execution (critical 10.0)
- [CVE-2026-27637](https://insights.sbomify.com/CVE-2026-27637/): FreeScout's Predictable Authentication Token Enables Account Takeover (critical 9.8)
- [CVE-2026-32754](https://insights.sbomify.com/CVE-2026-32754/): FreeScout: Stored XSS via Unescaped Email Template Rendering ({!! $thread->body !!}) (critical 9.3)
- [CVE-2024-29185](https://insights.sbomify.com/CVE-2024-29185/): FreeScout OS Command Injection vulnerability (critical 9.1)
- [CVE-2026-40498](https://insights.sbomify.com/CVE-2026-40498/): FreeScout has Authentication Bypass and Information Disclosure in SystemController via /system/cron (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58163 and fix it if it is affected.

What it is: CVE-2025-58163 is a high-severity unsafe deserialization vulnerability in freescout-help-desk freescout, published on 3 Sep 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-58163 in the wild and no public exploit code.

Affected product: freescout-help-desk freescout. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58163/ (Markdown: https://insights.sbomify.com/CVE-2025-58163/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58163
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58163
- OSV: https://osv.dev/vulnerability/CVE-2025-58163

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58163/
Summaries are generated and may contain mistakes; the official description above is the record.
