# CVE-2025-58172: drawnix debug logging cross-site scripting vulnerability


- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 15 Sep 2025
- **Updated:** 15 Sep 2025
- **Also known as:** GHSA-cq57-q8hg-xhxf

## What is CVE-2025-58172?

CVE-2025-58172 is a medium-severity vulnerability in plait-board drawnix, published on 15 Sep 2025. 

### Official description

drawnix is an all in one open-source whiteboard tool. In drawnix versions through 0.2.1, a cross-site scripting (XSS) vulnerability exists in the debug logging functionality. User controlled content is inserted directly into the DOM via innerHTML without sanitization when the global function __drawnix__web__console is invoked, as shown in apps/web/src/app/app.tsx where div.innerHTML = value is executed. This can allow arbitrary JavaScript execution in the context of the application if an attacker can cause untrusted data to be passed to the debug logger (for example via a malicious extension or other injection vector), potentially exposing user data or enabling unauthorized actions. The issue is fixed in version 0.3.0. Updating to 0.3.0 or later is recommended. No known workarounds exist.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-58172?


## How do I fix CVE-2025-58172?

No fix has been published for CVE-2025-58172 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-58172 being exploited?

There is no known exploitation of CVE-2025-58172 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58172 and fix it if it is affected.

What it is: CVE-2025-58172 is a medium-severity vulnerability in plait-board drawnix, published on 15 Sep 2025. 
Exploitation: There is no known exploitation of CVE-2025-58172 in the wild and no public exploit code.

Affected product: plait-board drawnix. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58172/ (Markdown: https://insights.sbomify.com/CVE-2025-58172/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58172
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58172
- OSV: https://osv.dev/vulnerability/CVE-2025-58172

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58172/
Summaries are generated and may contain mistakes; the official description above is the record.
