# CVE-2025-58174: LAM profile editor stored cross-site scripting vulnerability

> An authenticated user can inject malicious scripts into profile names, leading to code execution when viewed by other users.

- **Severity:** Medium 4.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Sep 2025
- **Updated:** 16 Sep 2025
- **Also known as:** DEBIAN-CVE-2025-58174, GHSA-6gqg-wm9x-5x3m, UBUNTU-CVE-2025-58174

## What is CVE-2025-58174?

CVE-2025-58174 is a medium-severity cross-site scripting vulnerability in LDAPAccountManager lam, published on 16 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

LDAP Account Manager (LAM) is a webfrontend for managing entries stored in an LDAP directory. LAM before 9.3 allows stored cross-site scripting in the Profile section via the profile name field, which renders untrusted input as HTML and executes a supplied script (for example a script element). An authenticated user with permission to create or edit a profile can insert a script payload into the profile name and have it executed when the profile data is viewed in a browser. This issue is fixed in version 9.3. No known workarounds are mentioned.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-58174?


## How do I fix CVE-2025-58174?

Upgrade to a fixed version.

## Is CVE-2025-58174 being exploited?

There is no known exploitation of CVE-2025-58174 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58174 and fix it if it is affected.

What it is: CVE-2025-58174 is a medium-severity cross-site scripting vulnerability in LDAPAccountManager lam, published on 16 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-58174 in the wild and no public exploit code.

Affected product: LDAPAccountManager lam. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58174/ (Markdown: https://insights.sbomify.com/CVE-2025-58174/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58174
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58174
- OSV: https://osv.dev/vulnerability/CVE-2025-58174

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58174/
Summaries are generated and may contain mistakes; the official description above is the record.
