CVE-2025-58175 GeoServer has a Server-Side Request Forgery (SSRF) Vulnerability in its XML Entity Resolution
Unauthenticated attackers can perform Server-Side Request Forgery in GeoServer when specific proxy and entity resolution settings are enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-58175?
CVE-2025-58175 is a medium-severity server-side request forgery vulnerability in org.geoserver.web:gs-web-app, published on 18 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
GeoServer is an open source server that allows users to share and edit geospatial data. Prior to versions 2.26.4 and 2.27.3, a GeoServer that uses `ENTITY_RESOLUTION_ALLOWLIST` may allow attacker to perform unauthenticated Server-Side Request Forgery (SSRF). This vulnerability requires that GeoServer is set up to use a proxy base URL and the `ENTITY_RESOLUTION_ALLOWLIST` (default since 2.25.0). Versions 2.26.4 and 2.27.3 contain a fix. GeoServer installations are only affected by this vulnerability if they use a proxy base URL that does not contain a URL path or end with a slash. If the proxy base URL does not contain a path, adding a slash to the end of the URL will mitigate this vulnerability.
Which versions are affected by CVE-2025-58175?
8 open source packages ship an affected version, including org.geoserver.web:gs-web-app and org.geoserver:gs-main. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.geoserver.web:gs-web-app Maven | All versions | 2.26.4 |
org.geoserver.web:gs-web-app Maven | All versions | 2.26.4 |
org.geoserver.web:gs-web-app Maven | From 2.27.0 | 2.27.3 |
org.geoserver.web:gs-web-app Maven | From 2.27.0 | 2.27.3 |
org.geoserver:gs-main Maven | All versions | 2.26.4 |
org.geoserver:gs-main Maven | All versions | 2.26.4 |
2 more packages
org.geoserver:gs-main Maven | From 2.27.0 | 2.27.3 |
org.geoserver:gs-main Maven | From 2.27.0 | 2.27.3 |
Products include Osgeo Geoserver.
How do I fix CVE-2025-58175?
Upgrade org.geoserver.web:gs-web-app to a fixed version for your release line: 2.26.4 or 2.27.3.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2025-58175 being exploited?
There is no known exploitation of CVE-2025-58175 in the wild and no public exploit code.
Other vulnerabilities in org.geoserver.web:gs-web-app
- CVE-2023-25157 Unfiltered SQL Injection Vulnerabilities in Geoserver
- CVE-2024-34711 GeoServer has improper ENTITY_RESOLUTION_ALLOWLIST URI validation in XML Processing (SSRF)
- CVE-2023-41339 Unsecured WMS dynamic styling sld=<url> parameter affords blind unauthenticated SSRF in GeoServer
- CVE-2023-43795 WPS Server Side Request Forgery in GeoServer
- CVE-2024-29198 GeoServer Vulnerable to Unauthenticated SSRF via TestWfsPost
Sources
Also known as GHSA-x4r9-gmw3-hxww.