CVE-2025-58177 n8n stored cross-site scripting in LangChain Chat Trigger node initialMessages parameter

Medium 5.4 Published Updated

An authorized user can inject malicious scripts into the LangChain Chat Trigger node, leading to XSS attacks against visitors of the public chat URL.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-58177?

CVE-2025-58177 is a medium-severity cross-site scripting vulnerability in N8n N8n, published on 15 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

n8n is an open source workflow automation platform. From 1.24.0 to before 1.107.0, there is a stored cross-site scripting (XSS) vulnerability in @n8n/n8n-nodes-langchain.chatTrigger. An authorized user can configure the LangChain Chat Trigger node with malicious JavaScript in the initialMessages field and enable public access so that the payload is executed in the browser of any user who visits the resulting public chat URL. This can be used for phishing or to steal cookies or other sensitive data from users accessing the public chat link. The issue is fixed in version 1.107.0. Updating to 1.107.0 or later is recommended. As a workaround, the affected chatTrigger node can be disabled. No other workarounds are known.

Weakness: CWE-79

Which versions are affected by CVE-2025-58177?

2 open source packages ship an affected version, including n8n. It affects 1 product.

PackageAffectedFixed in
n8n npmFrom 1.24.01.107.0
n8n npmFrom 1.24.01.107.0

Products include N8n N8n.

How do I fix CVE-2025-58177?

Upgrade n8n to 1.107.0 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-58177 being exploited?

There is no known exploitation of CVE-2025-58177 in the wild and no public exploit code.

All N8n N8n vulnerabilities

Sources

Also known as GHSA-mvh4-2cm2-6hpg.

Is CVE-2025-58177 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free