{"answers":{"affected":"2 open source packages ship an affected version, including n8n. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-58177 in the wild and no public exploit code.","fix":"Upgrade n8n to 1.107.0 or later.","what":"CVE-2025-58177 is a medium-severity cross-site scripting vulnerability in N8n N8n, published on 15 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-58177 and fix it if it is affected.\n\nWhat it is: CVE-2025-58177 is a medium-severity cross-site scripting vulnerability in N8n N8n, published on 15 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-58177 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- n8n (npm): affected from 1.24.0; fixed in 1.107.0\n- n8n (npm): affected from 1.24.0; fixed in 1.107.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-58177/ (Markdown: https://insights.sbomify.com/CVE-2025-58177/index.md)","id":"CVE-2025-58177","markdown":"https://insights.sbomify.com/CVE-2025-58177/index.md","name":"CVE-2025-58177","record":{"aliases":["GHSA-mvh4-2cm2-6hpg"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"n8n workflow automation","requires_auth":"low_privilege","summary":"An authorized user can inject malicious scripts into the LangChain Chat Trigger node, leading to XSS attacks against visitors of the public chat URL.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"n8n","vendor":"n8n"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"n8n is an open source workflow automation platform. From 1.24.0 to before 1.107.0, there is a stored cross-site scripting (XSS) vulnerability in @n8n/n8n-nodes-langchain.chatTrigger. An authorized user can configure the LangChain Chat Trigger node with malicious JavaScript in the initialMessages field and enable public access so that the payload is executed in the browser of any user who visits the resulting public chat URL. This can be used for phishing or to steal cookies or other sensitive data from users accessing the public chat link. The issue is fixed in version 1.107.0. Updating to 1.107.0 or later is recommended. As a workaround, the affected chatTrigger node can be disabled. No other workarounds are known.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"n8n stored cross-site scripting in LangChain Chat Trigger node initialMessages parameter","id":"CVE-2025-58177","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"n8n:n8n","products":["n8n:n8n"],"type":"xss","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"Command Injection via sonarqube-scan-action GitHub Action","id":"CVE-2025-58178"},"packages":[{"ecosystem":"npm","fixed":["1.107.0"],"introduced":["1.24.0"],"last_affected":[],"package":"n8n","purl":null,"source":"GHSA-mvh4-2cm2-6hpg"},{"ecosystem":"npm","fixed":["1.107.0"],"introduced":["1.24.0"],"last_affected":[],"package":"n8n","purl":"pkg:npm/n8n","source":"GHSA-mvh4-2cm2-6hpg"}],"prev":{"headline":"Dive's improper processing of custom urls can lead to Remote Code Execution","id":"CVE-2025-58176"},"products":["n8n"],"published":"2025-09-15","related":[{"cvss_score":10,"headline":"n8n Improper Control of Dynamically-Managed Code Resources","id":"CVE-2025-68613","kev_date_added":"2026-03-11","published":"2025-12-19"},{"cvss_score":10,"headline":"n8n is vulnerable to Remote Code Execution via Arbitrary File Write","id":"CVE-2026-21877","kev_date_added":null,"published":"2026-01-08"},{"cvss_score":10,"headline":"n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling","id":"CVE-2026-21858","kev_date_added":null,"published":"2026-01-07"},{"cvss_score":9.9,"headline":"n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution","id":"CVE-2026-1470","kev_date_added":null,"published":"2026-01-27"},{"cvss_score":9.9,"headline":"n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node","id":"CVE-2025-68668","kev_date_added":null,"published":"2025-12-26"},{"cvss_score":9.5,"headline":"n8n has Unauthenticated Expression Evaluation via Form Node","id":"CVE-2026-27493","kev_date_added":null,"published":"2026-02-25"},{"cvss_score":9.4,"headline":"n8n: HTTP Request Node Pagination Prototype Pollution to RCE","id":"CVE-2026-44789","kev_date_added":null,"published":"2026-06-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-09-15","vendors":["n8n-io"]},"summary":"An authorized user can inject malicious scripts into the LangChain Chat Trigger node, leading to XSS attacks against visitors of the public chat URL.","url":"https://insights.sbomify.com/CVE-2025-58177/"}