# CVE-2025-58177: n8n stored cross-site scripting in LangChain Chat Trigger node initialMessages parameter

> An authorized user can inject malicious scripts into the LangChain Chat Trigger node, leading to XSS attacks against visitors of the public chat URL.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Sep 2025
- **Updated:** 15 Sep 2025
- **Also known as:** GHSA-mvh4-2cm2-6hpg

## What is CVE-2025-58177?

CVE-2025-58177 is a medium-severity cross-site scripting vulnerability in N8n N8n, published on 15 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

n8n is an open source workflow automation platform. From 1.24.0 to before 1.107.0, there is a stored cross-site scripting (XSS) vulnerability in @n8n/n8n-nodes-langchain.chatTrigger. An authorized user can configure the LangChain Chat Trigger node with malicious JavaScript in the initialMessages field and enable public access so that the payload is executed in the browser of any user who visits the resulting public chat URL. This can be used for phishing or to steal cookies or other sensitive data from users accessing the public chat link. The issue is fixed in version 1.107.0. Updating to 1.107.0 or later is recommended. As a workaround, the affected chatTrigger node can be disabled. No other workarounds are known.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-58177?

2 open source packages ship an affected version, including n8n. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `n8n` | npm | From 1.24.0 | 1.107.0 |
| `n8n` | npm | From 1.24.0 | 1.107.0 |

Products: N8n N8n.

## How do I fix CVE-2025-58177?

Upgrade n8n to 1.107.0 or later.

## Is CVE-2025-58177 being exploited?

There is no known exploitation of CVE-2025-58177 in the wild and no public exploit code.

## Other vulnerabilities in N8n N8n

- [CVE-2025-68613](https://insights.sbomify.com/CVE-2025-68613/): n8n Improper Control of Dynamically-Managed Code Resources (critical 10.0, exploited in the wild)
- [CVE-2026-21877](https://insights.sbomify.com/CVE-2026-21877/): n8n is vulnerable to Remote Code Execution via Arbitrary File Write (critical 10.0)
- [CVE-2026-21858](https://insights.sbomify.com/CVE-2026-21858/): n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling (critical 10.0)
- [CVE-2026-1470](https://insights.sbomify.com/CVE-2026-1470/): n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution (critical 9.9)
- [CVE-2025-68668](https://insights.sbomify.com/CVE-2025-68668/): n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58177 and fix it if it is affected.

What it is: CVE-2025-58177 is a medium-severity cross-site scripting vulnerability in N8n N8n, published on 15 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-58177 in the wild and no public exploit code.

Affected packages and fixed versions:
- n8n (npm): affected from 1.24.0; fixed in 1.107.0
- n8n (npm): affected from 1.24.0; fixed in 1.107.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58177/ (Markdown: https://insights.sbomify.com/CVE-2025-58177/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58177
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58177
- OSV: https://osv.dev/vulnerability/CVE-2025-58177

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58177/
Summaries are generated and may contain mistakes; the official description above is the record.
