# CVE-2025-58180: OctoPrint is Vulnerable to RCE Attacks via Unsanitized Filename in File Upload

> Authenticated attackers can execute arbitrary commands via crafted filenames in OctoPrint if system event handlers are configured.

- **Severity:** High 7.5 (`CVSS:4.0/AV:A/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Sep 2025
- **Updated:** 10 Sep 2025
- **Also known as:** GHSA-49mj-x8jp-qvfc, PYSEC-2026-1712

## What is CVE-2025-58180?

CVE-2025-58180 is a high-severity command injection vulnerability in OctoPrint, published on 9 Sep 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

OctoPrint provides a web interface for controlling consumer 3D printers. OctoPrint versions up until and including 1.11.2 contain a vulnerability that allows an authenticated attacker to upload a file under a specially crafted filename that will allow arbitrary command execution if said filename becomes included in a command defined in a system event handler and said event gets triggered. If no event handlers executing system commands with uploaded filenames as parameters have been configured, this vulnerability does not have an impact. The vulnerability is patched in version 1.11.3. As a workaround, OctoPrint administrators who have event handlers configured that include any kind of filename based placeholders should disable those by setting their `enabled` property to `False` or unchecking the "Enabled" checkbox in the GUI based Event Manager. Alternatively, OctoPrint administrators should set `feature.enforceReallyUniversalFilenames` to `true` in `config.yaml` and restart OctoPrint, then vet the existing uploads and make sure to delete any suspicious looking files. As always, OctoPrint administrators are advised to not expose OctoPrint on hostile networks like the public internet, and to vet who has access to their instance.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2025-58180?

3 open source packages ship an affected version, including octoprint. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `octoprint` | PyPI | All versions | 1.11.3 |
| `octoprint` | PyPI | All versions | 1.11.3 |
| `octoprint` | PyPI | All versions | 1.11.3 |

Products: Octoprint Octoprint.

## How do I fix CVE-2025-58180?

Upgrade octoprint to 1.11.3 or later.

## Is CVE-2025-58180 being exploited?

There is no known exploitation of CVE-2025-58180 in the wild and no public exploit code.

Public exploit code:

- In OctoPrint version <=1.11.2, an attacker with file upload access (e.g., valid API key or session) can craft a malicious filename that bypasses sanitization and is later executed by OctoPrint’s event system, leading to remote code execution (RCE) on the host (github_poc): https://github.com/prabhatverma47/CVE-2025-58180
- OctoPrint 1.11.2 - File Upload (exploitdb)

## Other vulnerabilities in OctoPrint

- [CVE-2018-16710](https://insights.sbomify.com/CVE-2018-16710/): Information disclosure in n/a (critical 9.1)
- [CVE-2022-1430](https://insights.sbomify.com/CVE-2022-1430/): Cross-site Scripting (XSS) - DOM in octoprint/octoprint (high 7.5)
- [CVE-2022-1432](https://insights.sbomify.com/CVE-2022-1432/): Cross-site Scripting (XSS) - Generic in octoprint/octoprint (high 7.5)
- [CVE-2024-32977](https://insights.sbomify.com/CVE-2024-32977/): OctoPrint Authentication Bypass via X-Forwarded-For Header when autologinLocal is enabled (high 7.1)
- [CVE-2025-48879](https://insights.sbomify.com/CVE-2025-48879/): OctoPrint Vulnerable to Denial of Service through malformed HTTP request (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58180 and fix it if it is affected.

What it is: CVE-2025-58180 is a high-severity command injection vulnerability in OctoPrint, published on 9 Sep 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-58180 in the wild and no public exploit code.

Affected packages and fixed versions:
- octoprint (PyPI): affected all versions; fixed in 1.11.3
- octoprint (PyPI): affected all versions; fixed in 1.11.3
- octoprint (PyPI): affected all versions; fixed in 1.11.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58180/ (Markdown: https://insights.sbomify.com/CVE-2025-58180/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58180
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58180
- OSV: https://osv.dev/vulnerability/CVE-2025-58180

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58180/
Summaries are generated and may contain mistakes; the official description above is the record.
