CVE-2025-5819 Incorrect Permission Assignment for Critical Resource in GitLab
Authenticated developers can obtain ID tokens for protected branches, bypassing intended access controls in GitLab.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-5819?
CVE-2025-5819 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 13 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue has been discovered in GitLab CE/EE affecting all versions from 15.7 before 18.0.6, 18.1 before 18.1.4, and 18.2 before 18.2.2 that could have allowed authenticated users with developer access to obtain ID tokens for protected branches under certain circumstances.
Weakness: CWE-732
Which versions are affected by CVE-2025-5819?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 15.7.0 | 18.0.6, 18.1.4, 18.2.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2025-5819?
Upgrade gitlab to a fixed version for your release line: 18.0.6, 18.1.4 or 18.2.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-5819 being exploited?
There is no known exploitation of CVE-2025-5819 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2025-5819, GHSA-pvxr-g7hw-fv88, UBUNTU-CVE-2025-5819.