# CVE-2025-58236: WordPress Force Update Translations plugin <= 0.5 - Cross Site Request Forgery (CSRF) vulnerability

> Attackers can trick administrators into performing unintended actions via CSRF in the Force Update Translations plugin.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 22 Sep 2025
- **Updated:** 13 May 2026
- **Also known as:** GHSA-4whg-r768-vrgw

## What is CVE-2025-58236?

CVE-2025-58236 is a medium-severity vulnerability in Mayo Moriyama Force Update Translations, published on 22 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-Site Request Forgery (CSRF) vulnerability in Mayo Moriyama Force Update Translations force-update-translations allows Cross Site Request Forgery.This issue affects Force Update Translations: from n/a through <= 0.5.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2025-58236?


## How do I fix CVE-2025-58236?

No fix has been published for CVE-2025-58236 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-58236 being exploited?

There is no known exploitation of CVE-2025-58236 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-58236 and fix it if it is affected.

What it is: CVE-2025-58236 is a medium-severity vulnerability in Mayo Moriyama Force Update Translations, published on 22 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-58236 in the wild and no public exploit code.

Affected product: Mayo Moriyama Force Update Translations. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-58236/ (Markdown: https://insights.sbomify.com/CVE-2025-58236/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-58236
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-58236
- OSV: https://osv.dev/vulnerability/CVE-2025-58236

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-58236/
Summaries are generated and may contain mistakes; the official description above is the record.
