CVE-2025-58246 WordPress <= 6.8.2 - (Contributor+) Sensitive Data Exposure Vulnerability
Contributors can expose sensitive data via embedded content in WordPress, requiring an upgrade to mitigate the low-severity information disclosure risk.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-58246?
CVE-2025-58246 is a medium-severity vulnerability in WordPress, published on 23 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Insertion of Sensitive Information Into Sent Data vulnerability in WordPress allows Retrieve Embedded Sensitive Data. The WordPress Core security team is aware of the issue and is already working on a fix. This is a low-severity vulnerability. Contributor-level privileges required in order to exploit it. This issue affects WordPress: from 6.8 through 6.8.2, from 6.7 through 6.7.3, from 6.6 through 6.6.3, from 6.5 through 6.5.6, from 6.4 through 6.4.6, from 6.3 through 6.3.6, from 6.2 through 6.2.7, from 6.1 through 6.1.8, from 6.0 through 6.0.10, from 5.9 through 5.9.11, from 5.8 through 5.8.11, from 5.7 through 5.7.13, from 5.6 through 5.6.15, from 5.5 through 5.5.16, from 5.4 through 5.4.17, from 5.3 through 5.3.19, from 5.2 through 5.2.22, from 5.1 through 5.1.20, from 5.0 through 5.0.23, from 4.9 through 4.9.27, from 4.8 through 4.8.26, from 4.7 through 4.7.30.
Weakness: CWE-201
Which versions are affected by CVE-2025-58246?
2 open source packages ship an affected version, including wordpress and wordpress-multisite.
| Package | Affected | Fixed in |
|---|---|---|
wordpress Bitnami | All versions | 6.8.3 |
wordpress-multisite Bitnami | All versions | 6.8.3 |
How do I fix CVE-2025-58246?
Upgrade wordpress to 6.8.3 or later.
Is CVE-2025-58246 being exploited?
There is no known exploitation of CVE-2025-58246 in the wild and no public exploit code.
Sources
Also known as BIT-wordpress-2025-58246, BIT-wordpress-multisite-2025-58246, DEBIAN-CVE-2025-58246, GHSA-9cxg-grmq-54mq, MINI-q8r6-7wjw-84vf, UBUNTU-CVE-2025-58246.