{"answers":{"affected":"2 open source packages ship an affected version, including wordpress and wordpress-multisite.","exploited":"There is no known exploitation of CVE-2025-58246 in the wild and no public exploit code.","fix":"Upgrade wordpress to 6.8.3 or later.","what":"CVE-2025-58246 is a medium-severity vulnerability in WordPress, published on 23 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-58246 and fix it if it is affected.\n\nWhat it is: CVE-2025-58246 is a medium-severity vulnerability in WordPress, published on 23 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-58246 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wordpress (Bitnami): affected all versions; fixed in 6.8.3\n- wordpress-multisite (Bitnami): affected all versions; fixed in 6.8.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-58246/ (Markdown: https://insights.sbomify.com/CVE-2025-58246/index.md)","id":"CVE-2025-58246","markdown":"https://insights.sbomify.com/CVE-2025-58246/index.md","name":"CVE-2025-58246","record":{"aliases":["BIT-wordpress-2025-58246","BIT-wordpress-multisite-2025-58246","DEBIAN-CVE-2025-58246","GHSA-9cxg-grmq-54mq","MINI-q8r6-7wjw-84vf","UBUNTU-CVE-2025-58246"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress core","requires_auth":"low_privilege","summary":"Contributors can expose sensitive data via embedded content in WordPress, requiring an upgrade to mitigate the low-severity information disclosure risk.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Patchstack","cpe":[],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-201","name":"Insertion of Sensitive Information Into Sent Data"}],"description":"Insertion of Sensitive Information Into Sent Data vulnerability in WordPress allows Retrieve Embedded Sensitive Data. The WordPress Core security team is aware of the issue and is already working on a fix. This is a low-severity vulnerability. Contributor-level privileges required in order to exploit it.\nThis issue affects WordPress: from 6.8 through 6.8.2, from 6.7 through 6.7.3, from 6.6 through 6.6.3, from 6.5 through 6.5.6, from 6.4 through 6.4.6, from 6.3 through 6.3.6, from 6.2 through 6.2.7, from 6.1 through 6.1.8, from 6.0 through 6.0.10, from 5.9 through 5.9.11, from 5.8 through 5.8.11, from 5.7 through 5.7.13, from 5.6 through 5.6.15, from 5.5 through 5.5.16, from 5.4 through 5.4.17, from 5.3 through 5.3.19, from 5.2 through 5.2.22, from 5.1 through 5.1.20, from 5.0 through 5.0.23, from 4.9 through 4.9.27, from 4.8 through 4.8.26, from 4.7 through 4.7.30.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"WordPress \u003c= 6.8.2 - (Contributor+) Sensitive Data Exposure Vulnerability","id":"CVE-2025-58246","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"information_disclosure","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"WordPress TI WooCommerce Wishlist plugin \u003c= 2.10.0 - Broken Access Control vulnerability","id":"CVE-2025-58247"},"packages":[{"ecosystem":"Bitnami","fixed":["6.8.3"],"introduced":["0"],"last_affected":[],"package":"wordpress","purl":"pkg:bitnami/wordpress","source":"BIT-wordpress-2025-58246"},{"ecosystem":"Bitnami","fixed":["6.8.3"],"introduced":["0"],"last_affected":[],"package":"wordpress-multisite","purl":"pkg:bitnami/wordpress-multisite","source":"BIT-wordpress-multisite-2025-58246"}],"prev":{"headline":"WordPress Portfolio Plugin \u003c= 2.58 - Cross Site Scripting (XSS) Vulnerability","id":"CVE-2025-58245"},"products":["WordPress"],"published":"2025-09-23","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-28","vendors":["WordPress"]},"summary":"Contributors can expose sensitive data via embedded content in WordPress, requiring an upgrade to mitigate the low-severity information disclosure risk.","url":"https://insights.sbomify.com/CVE-2025-58246/"}