{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2025-58266 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2025-58266 is a medium-severity cross-site scripting vulnerability in Fumiki Takahashi Gianism, published on 22 Sep 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-58266 and fix it if it is affected.\n\nWhat it is: CVE-2025-58266 is a medium-severity cross-site scripting vulnerability in Fumiki Takahashi Gianism, published on 22 Sep 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-58266 in the wild and no public exploit code.\n\nAffected product: Fumiki Takahashi Gianism. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-58266/ (Markdown: https://insights.sbomify.com/CVE-2025-58266/index.md)","id":"CVE-2025-58266","markdown":"https://insights.sbomify.com/CVE-2025-58266/index.md","name":"CVE-2025-58266","record":{"aliases":["GHSA-37q7-p6vr-5j9p","openSUSE-SU-2025:15426-1"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"high_privilege","summary":"Stored XSS in Gianism plugin allows attackers to inject malicious scripts, potentially leading to session hijacking or code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Patchstack","cpe":[],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Fumiki Takahashi Gianism gianism allows Stored XSS.This issue affects Gianism: from n/a through \u003c= 6.0.0.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"WordPress Gianism plugin \u003c= 6.0.0 - Cross Site Scripting (XSS) vulnerability","id":"CVE-2025-58266","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2025"},"n_packages":1,"n_references":1,"next":{"headline":"WordPress Stock Message Plugin \u003c= 1.1.0 - Cross Site Request Forgery (CSRF) Vulnerability","id":"CVE-2025-58267"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.2.7+141-1.1"],"introduced":["0"],"last_affected":[],"package":"rust-keylime","purl":"pkg:rpm/opensuse/rust-keylime\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15426-1"}],"prev":{"headline":"WordPress Events Manager – OpenStreetMaps Plugin \u003c= 4.2.1 - Cross Site Scripting (XSS) Vulnerability","id":"CVE-2025-58265"},"products":["Gianism"],"published":"2025-09-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-13","vendors":["Fumiki Takahashi"]},"summary":"Stored XSS in Gianism plugin allows attackers to inject malicious scripts, potentially leading to session hijacking or code execution.","url":"https://insights.sbomify.com/CVE-2025-58266/"}